Skip to Content

How to delete a link to a non-existing program

Nov 10, 2017 at 03:46 PM


avatar image

I deleted a database table after checking its where-used linkage over data dictionary (se11).

I also deleted the related functions and generated table maintenance views.

After transporting the changes into the production System the changes did not take place.

In the developing System everything is deleted. At least i thought so. By checking the Where-Used list on the deleted db-table i get a result for the include of the function Group. But the result is empty if you try to expand it. The info "Program LZ****T00 not found" appears in the infobar (Message no. ED524).

How can i delete this link to fully delete the db-table Transport it to production System?

Kind regards

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Mike Pokraka Nov 10, 2017 at 04:45 PM

In your transport request you probably had the individual function module deletions. This would still leave the function group behind.

Please look at your transport request, it will probably contain LIMU/FUNC entries.

You can create a new transport request and manually add a R3TR/FUGR entry to force the system to delete the entire group.

Edit: I'm not thinking, you don't need to do this manually and it will still leave the FG in your dev system. Just go to SE37 and from the menu Goto > Function Groups > Delete should clean your dev system and create the correct transport request (you can doublecheck using the info I wrote up above).

Show 9 Share
10 |10000 characters needed characters left characters exceeded

Goto > Function Groups > Delete

Or simpler in SE80 (or ADT)?


Neither the function group, nor the function module are existent in se37 or se80. It is only existent when I make a where-used check on the already deleted DB-table. I also tried to undo the deletion of the DB-table and the function group. After that I then deleted them again. Resulting in the same strange behavior of leaving behind an empty non-existing program link in the where-used analysis.

There must be another entry where the system gets this entry from. I also couldn't figure out where using the debugger.


Can you search table TADIR for *ABC* , where ABC is some identifying piece of your object name (important, don't use Z*ABC*) to see what is still in the system. Maybe also do the same in TRDIR in case something really is inconsistent.

As a matter of curiosity, how do you do a where-used on a deleted table?


Go to SE11 and type in the deleted table name. Do a Where-Used List (Ctrl+Shift+F3) -> confirm the Information (Enter) -> choose search criteria (Enter) -> Yes (Enter) . Et voila, the result is presented if something is found.


Nice catch Mike :-) :-)

As you had already deleted the table, actually at this level SE11 should say table doesn't exist but here you were still able to see results of where-used list for a deleted table.

Seems there is still some referrence left in any of the Table Maintenance Generator INCLUDES for that deleted table.


Kindly check with the Basis team to confirm whether table got deleted at the DB level.



Curiosity got the better of me so I tried it and doesn't work on our 7.5 HANA system:

Added a select on a table in a program. Deleted table - got warnings that it's still in use and hit the dustbin again to tell it to go ahead. Now the where-used says the table doesn't exist.

If I get some spare time I might try it on 7.4, what DB/version are you using?


I got the warning aswell that the table does not exist, but the where-used list still works. The result for the "non existing" program delivers only the name without being able to check the code of it. DB is Oracle/ . SAP is Version 7.0 SP31.


I suspect you're probably using a loophole that's no longer possible in later versions.

It might be worth regenerating the program index, tx SGEN and regenerate the packages of your table and the FMs. Be careful not to regenerate everything, it can run for days.


Thank you very much for your help Mike Pokraka. The Programm is not listed anymore and the transport could be finished correctly.