Skip to Content
author's profile photo Former Member
Former Member

Idoc 2 File(Idoc not getting posted on to XI)

Hi All,

XI system is not getting the Idoc which is triggered from R/3. I have maintained all the required configurations on R/3 as well XI systems. Find them below

Configurations on R/3:

RFC(SM 59): RFC_SJ_DEST_TEST to connect with XI, this is working fine and I am able to remote login to XI.

Port(WE21): PORT_TEST with RFC_SJ_DEST_TEST destiantion.

Logical System(BD54): IDOCTOFILE

Distribution Model(BD64): Maintained Message types and genertated partner profile

Partner Profile(WE20): Used Matmas03 as outbound

Adapter port(IDX1): Maintained the Port with the following data

Port as the same port of R/3 PORT_TEST

Client as XI Clinet 010

RFC destination as RFC_SJ_DEST_TEST

Configurations on XI:

RFC(SM 59): RFC_SJ_DEST_TEST1 to connect with R/3, this is working fine and I am able to remote login to R/3.

Port (IDX1): created a port with following data

Port as the same port of R/3 PORT_TEST

Client as R/3 Clinet 800

RFC destination as RFC_SJ_DEST_TEST1.

Metadata(IDX2): Imported the Metadata successfull in IDX2.

Altough I have done all the configurations correct and used the same in in the ID of XI, I was not able to get the data into XI.

Please help me

Thanks in Advance,

Srikanth

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

10 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 21, 2008 at 11:01 AM

    Hi,

    Is your IDOC sent successfully from R3?

    u can check this in we02......... it shd be with green status.

    Check the outpu mode in partner profile............. it shd be Transfer IDoc Immed.

    Thanks,

    Maheshwari.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 21, 2008 at 10:42 AM

    Hi,

    Ru usiing the Existed metadata which was uploaded in IDX2,or have u extented ur IDOC...if yes or if u dont just delete the Metadat in idx2 TC and upload it again. it will work iam sure

    This happen to me lot of time....

    Update the thread if it is still not working...

    Regards,

    Phani

    Reward points if Helpful 😊

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 21, 2008 at 11:40 AM

    Hi All,

    Thanks for sparing your valuble time in answering, Now I am able to see the message in SXMB_Moni but, there is no flag displayed, It showing an error no No receiver could be determined.

    What this error states??

    Thanks and Regards,

    Srikanth

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 21, 2008 at 11:45 AM

    Hello,

    check the receiver determination is configured or not.

    Also check the receiver agreement.

    Thanks,

    Maheshwari.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 22, 2008 at 07:05 AM

    Hi,

    i guess u might not have done the receiver determination configuration properly.check whether its activated or not

    also

    GOTO transaction SXI_CACHE And do the complete cache refresh.because at runtime xi sees for all the confiuration frm cache.it should be updated

    Regards

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 21, 2008 at 10:29 AM

    check sm58, we02 on r/3 side

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 21, 2008 at 10:43 AM

    Hi,

    you are doing Idoc-file scenario.

    may i know how you are triggering the idoc.

    i mean how you are testing the scenario.

    Regards

    mahesh.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 21, 2008 at 10:49 AM

    Check the authorizations of the user used in SM59(RFC destination) of R3 side...

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 22, 2008 at 07:31 AM

    Hi,

    - Log in to sender system, go to transaction WE19 (test tool to generate IDoc), generate IDoc of the required message type

    - In the following screen follow the steps : Give Receiver and Sender System Info(Port, Partner No, Port Type and Message Type) and click on Continue

    - Now put some entry into the IDoc before you send

    -Now click on Standard outbound processing button then : Click on continue again continue. In the last window Idoc sent to Sap system or external program information should appear else you may have to check Receiver and Sender System Info(Port, Partner No, Port Type and Message Type) for valid entry.

    - Execute Transaction WE05; enter correct date/time frame and logical message type. Hopefully the Idoc Status should be 3 (successful), if not check the status code and correct the error and reprocess the message. You can use transaction code SM58 with enter correct date/time frame and execute. Here if it is successful then nothing should be available in the list else it will show the relevant Status / Message. WE02 transaction can be used to get the error info.

    - Log in to Xi system and execute transaction SXMB_MONI and check for the XML messages. Use your source and destination system to filter messages

    - Check the destination directory, it should have file with the name specified. Check the file; it should have data for all segments

    Hope this will help you.

    Regards

    Aashish Sinha

    PS : reward points if helpful

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 22, 2008 at 10:09 AM

    Thanks for the Support I have given points to the helpfull answers

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.