Skip to Content

SAP Analytics Cloud - Hana live data connection

Nov 07, 2017 at 12:00 PM


avatar image


We managed to connect successfully to DEV by Hana live data connection. It seems impossible to connect to QAS. Credentials and CORS are correct.Also we checked URL ".../sap/bc/ina/service/v2/GetServerInfo"

And the user we are using for this already has this permissions:

  • sap.bc.ina.service.v2.userRole::INA_USER
  • sap.hana.xs.admin.roles::HTTPDestAdministrator
  • sap.hana.ide.roles::EditorDeveloper

Nothing seems to work. Any ideas?
Thank you.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Mark Fodor
Nov 07, 2017 at 09:58 PM

Hello Florencia Robledo ,

I have a feeling you are facing a "Failed to connect to system" error when setting up the connection in SAC.
In some cases there is issue with the HANA HTTPS certificate which must be trusted by your browser... could you please take a look at this Master KBA where we collected many reasons and solutions for this error here: 2544696

What I'd also suggest you is to compare the settings you made in the xsaccess file (http://hanahost:port/sap/hana/ide/editor/) as well what is visible in the XS Admin Tool (http://hanahost:port/sap/hana/xs/admin/#/package/sap.bc.ina.service.v2) page.

I've seen cases where the two did not match therefore connection was not working.

Thanks, Mark

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hello Mark,

Finally, the issue was a firewall filtered out the OPTIONS requests.

Thank you anyway.


Florencia Robledo

Hi Florencia,

Thanks for updating this thread with the solution.

Cheers, Mark