Skip to Content

How do you print with old data in Crystal Reports 11?

Nov 06, 2017 at 04:47 PM


avatar image

We've recently upgraded our computer system.

Part of this process included upgrading Crystal Reports from version 8.5 to version 11. The operating system on the new computer is the same version as was on the old computer (Windows 7).

In order to print what we want to print, we've had to design a custom form.

When we open the old form in Crystal Reports 11, it says "this report uses an invalid printer. The default printer will be used instead."

Initially I didn't think this was a huge deal, as you can always go in and specify the printer and the form size in print options, which was what the plan was.

However, when I try to do that, the program crashes.

The proposed workaround was to just redesign the old form so that we can print what we want on the default printer, effectively making it a new form.

I tried to see if it would print if we didn't change anything with the old form, specify a new printer, or paper size. Even if no setting changes and we just try to print the form as-is, the program crashes and we're not allowed to print.

The solution proposed here: did not end up being too helpful in actually solving the issue.

When we try to select the "no printer" option and implement the proposed fix, the program crashes and doesn't allow us to save that setting.

If we were to reinstall the driver for the printer, that's fine, but it shouldn't crash when we try to tell it to print to what it sees as a new printer. I would think we should just be allowed to set these printer settings without a problem.

Any help would be appreciated.
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Abhilash Kumar
Nov 07, 2017 at 01:34 PM

Hi Zack,

Could you confirm if you're using CR XI or CR 2011?

If it is the old CR XI developer, could you make sure you're on SP6:

Please follow this blog on how to get to SP6:


Show 1 Share
10 |10000 characters needed characters left characters exceeded


This solved our problem. We can print now. Thank you very much.

Many Blessings,

Zack Babb