Skip to Content
avatar image
Former Member

Smart Table- Analytical Table Type on scrolling the table selection Row index is retaining

Hi All,

We are using Analytical table with selection mode:Multiple.

On selection of row we are enabling Input box of selected row and on unselecting the row we are disabling the input box. It was working as expected.

Issue is when I scroll the table which ever row comes to the position of selected row index with out selecting that row input field is enabled.

PFB screen shot where I select 2 rows and Input is enabled for both

PFB , where I scroll down and though rows are not selected but when they came to place of previously selected index its making them enabled

Could anyone please help

Thanks,

Best Regards,

Viswanath

selected.png (9.4 kB)
unselected.png (15.7 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Nov 08, 2017 at 11:48 AM

    this is a common scenario where you are probably using the index of the table.... so when you scroll.... the index (visible) is still the same... instead, you should control the control properties (enabled, visible, selected, etc) via your data model. so in your object property you get/set the value via the model, for example:

    <Checkbox selected="/pathToYourPropertySelected" />

    <DatePicker enabled="/pathToYourPropertySelected" />

    hope this helps

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Sergio,

      Thanks for your response.

      Actually we are not explicitly using any check box for selection , the check box shown above was the row selection check box in analytical table. As you said on selection of row we are enabling the input field using row index and Column Index.

      If we set enabled through model, it will set enabled for all the rows. Correct me if I am wrong.

      Kindly suggest how to achieve this functionality on selection of Row only that particular Row's Input field should be enabled.

      Thanks,

      Best Regards,

      Viswanath