Skip to Content
avatar image
Former Member

ABAP Proxy does not send data to XI system.

I have a very simple program to test an ABAP Proxy:

REPORT Z_TEST_PERSON_OB.

DATA prxy TYPE REF TO Z996CO_PERSON_OB2.

*

CREATE OBJECT prxy.

DATA person TYPE Z996PERSON_MT .

*TRY.

person-person_mt-first_name = 'Ken and Kenneth'.

person-person_mt-Series = 'The Fast Show'.

person-person_mt-motto = 'Ooh, suit you Sir!'.

CALL METHOD prxy->execute_asynchronous

EXPORTING

output = person.

commit work.

I removed any exception handling to see if it would dump. Nothing. Seems to work fine, but no data appears in the XI Integration Engine monitor. I checked the scenario in XI and tested it; again, seems to work fine.

Could I have missed something in setting up the system? Any pointers highly appreciated.

BR,

Tony.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Jan 18, 2008 at 02:36 AM

    Can you check SXMB_MONI on your R3. This should give you a idea of what is going wrong.

    Regards

    Bhavesh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 25, 2008 at 02:50 PM

    Try the Message Monitoring -> Messages from component 'Proxy Runtime <...>'.

    That's where I found my Messages back (Status: To Be Delivered...)

    If this is the case, probably your Proxy Runtime does send the messages to the Integration Engine.

    Check the queues:

    Transaction SXMB_ADM on the Business system (the system that sends the Proxy)

    • Integration Engine > Administration > Manage Queues

    • All queues should be checked

    • Click ‘Register Queues’. Status bar should display a ‘Success message’.

    • Click ‘Activate Queues’. Status bar should display a ‘Success message’.

    If it still does not work, maybe the is no connection between Integration Builder and Runtime Workbench.

    Check SM59 on your ECC-business system (the system that sends the Proxy). It should have the Connection INTEGRATION_DIRECTORY_HMI (type H). If not, this is the problem.

    Create a new connection INTEGRATION_DIRECTORY_HMI, type H.

    • Tab Technical settings:

    Target Host is your XI-host

    Service No. 5xx00 (xx is the instance number of your XI-system)

    Path Prefix is "/dir/hmi_cache_refresh_service/ext" (without quotes)

    • Tab Logon & Security

    Logon Procedure is "Basic Authentication"

    Logon using XIISUSER (or PIISUSER)

    • Tab special Options

    Specify timeout: set to 900 msec.

    Compression Status should be 'inactive'

    Compressed response: No

    Accept Cookies: Yes (all)

    Save configuration and test connection. Popup about cookies appears. Check the "Accept All Further Cookies"option.

    The response should have HTTP/1.1 200 OK in the first line of the response header.

    Now your Proxy Runtime should be able to connect the Integration Engine.

    Greetings, Frank

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 26, 2008 at 08:52 AM

    Hi,

    you have to check the following

    1) Check with the O/B Queues smq1 in R/3 side

    2) Check in SXMB_MONI in R/3 side

    3) Check with queues I/B queues SMq2 in XI side

    4)Check the RFC Connection type H which is created in R/3 is success or not

    Check with this Debugging guide

    https://weblogs.sdn.sap.com/pub/wlg/4098--Debugging [original link is broken] [original link is broken] [original link is broken]

    Make sure that you have activated the Proxy in R/3

    Regards

    Seshagiri

    Edited by: N V Seshagiri on Feb 26, 2008 9:56 AM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 26, 2008 at 08:54 AM

    Try

    TX: SPROXY -> Goto -> Connection Test

    and see if everything tests fine.

    Add comment
    10|10000 characters needed characters exceeded