Skip to Content
author's profile photo Former Member
Former Member

xl reporter

hai ,

i am srinivas, i got the problem when genarating report in

Xl reporter in sap b1 2005B with msoffice 2003+sp2.

i got the error message that security setting in ms excel prohibit xlreporter from running. please resolve my problem

Regards

Srinivas

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 17, 2008 at 09:02 PM

    Hi,

    For SAP Business One and XL Reporter there are two security settings you need to set in Excel, the first is you need to set the Macro Securtity to Medium or Low. The second is to select:

    Tools / Options

    Then on the Security Tab choose Macro Security

    Click on Trusted Publishers and then you must ensure that you have ticked "Trust Access to Visual Basic Project"

    The visual basic project setting is normally unticked so you must tick that.

    If this resolves your issue please mark this as answered.

    Regards,

    Adrian

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 17, 2008 at 08:10 AM

    Check security settings for macros in ms excell.

    Petr

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Srinivas,

      If still getting the security message error, please try the following :

      - Open your excel application

      - Go to Help > About MS Excel

      - Click on the > Disabled items > if having B1 excel reporter (XLR) listed

      - Select the XLR > Click on 'Enable'

      Go back to the XLR add-on an try to open the report once again.

      Hoping this could solve your issue.

      Juan Manuel Marrero

  • author's profile photo Former Member
    Former Member
    Posted on Jan 17, 2008 at 09:12 AM

    HI

    open Microsoft Excel then goto

    Tools >Macro >Security-->under Trusted Publishers Tab check(select the check box) Trust all installed add-ins and templates

    Hope it helps you

    Regards

    Vishnu

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.