Skip to Content

Why does it take forever for the prompt to populate

Hello,

We have BO 4.1 sp3 on Windows 2008? . We're hosted.

My question is why does it take so long for a prompt to populate?

When trying to schedule a report and fill in the prompt values, it sometimes take minutes for a simple prompt to appear. I've noticed this in other parts of the application.

I noticed this starting to happen when we moved from v3.1 to v4.1. I have been told it is due to the new architecture of the v4.1. My ultimate goal is to somehow improve this wait time.

It appears to me that any time the application is needing to generated the sql that this appears to happen.

Thanks in advance! Scott

Add comment
10|10000 characters needed characters exceeded

  • Former Member

    Hi Scott,

    How you're going with this issue, have you found solution?
    We experienced same kind of issue after upgrading from XI3.1 to BI4.1. Unfortunately we have not found solution for this.

    At first we noticed that it took very long time to populate prompts. When we try to schedule a report and fill in the prompt values, it takes three times longer t that in XI3.1 for a prompt to appear.

    In further investigation revealed that generation of SQL in Universe with Web Intelligence & Universe Designer takes a long time.

    Due to this:
    * Significant amount of the time when refreshing a report is spent on SQL generation not on query refresh.
    * Prompt list of values takes a long time to populate
    * In Universe Design Tool, edit list of values takes a long time

    Regards,
    Jana

  • Sorry this is so late but no I have not gotten a solution or answer.

  • Get RSS Feed

3 Answers

  • Oct 17, 2016 at 03:39 PM
    Add comment
    10|10000 characters needed characters exceeded

    • Amit,

      Thank you for your time and support! I did look at your link. Much of witch I suspect may have a baring on this situation, however, I don't understand why the problem is more pronounced with the newer version of BO?

  • Oct 17, 2016 at 03:46 PM

    Basic stuff is, you should always reference Dimension table instead of Aggregate table when you try to use an LOV of an dimension object.

    Thanks

    Mani

    Add comment
    10|10000 characters needed characters exceeded

    • In my opinion there shouldnt be a problem with your version. It would be nice if you could share more details about your LOV. It should be something to do with the Dimension itself. Did you tried to generate the values in IDT/UDT? How do they performing compared to BI 3.x?

      Thanks

      Mani

  • Oct 19, 2016 at 07:18 PM

    Manikandan,

    Thank you! The specific LOV doesn't appear to be the issue since it happens with multiple different LOVs/Queries. What is IDT/UDT. Universe Design Tool and ? In the old the prompts populate within seconds compared to minutes now. Based on what someone else has told me, I thought that this was a known issue and that you might be able to direct me to a back end service/server that needed a memory setting changed. I'll put together the results from comparing what a specific LOV/Query does in universe designer versus webi and post those results. Again thanks for looking into this.

    Scott

    Add comment
    10|10000 characters needed characters exceeded