Skip to Content
author's profile photo Former Member
Former Member

Workflow doesnot automatically trigger mail ..

Hi MDM Gurus,

I am trying to design a simple workflow

Start >Process >Approve-->Stop.

This flow Or workflow works and does trigger a mail to approver and processer when i execute the workflow Manually .i.e In Datamgr i select the record... go to records in header --workflow and execute the corresponding workflow..evrything works fine..

But when i put the XML file in ready folder(to automatically suck into datamanager with help of MDIS server) of respective repository..Workflow doesnot trigger a mail...What can be the reason ..I have checked the mds.ini file and it has server path in it.

Please can anyone let me know what can be the problem...

Regards,

Vikrant...

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 16, 2008 at 06:19 AM

    Hi Vikrant

    If you want the workflow to be launched automatically upon import of records/file you need to give the workflow name in the COnfiguration options in Import manager,

    Open import manager go to Config Options>>Checkout/workflow option >>select workflow name that u want to launch>>OK

    This should work but it has some performance issues whihc you need to be cautious about.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 16, 2008 at 05:39 AM

    Hi Vikrant,

    Try executing the workflow manually check wether it can send the mail.

    If it cannot send the mail then check wether the mail.server name is proper.

    and check user email address in Console who will get notified.

    Hope dis helps u

    Regards Tejas...........

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Vikrant,

      As u said u can execute workflows for mail manually but not automatically.

      Are u sure that while automatic import of xml file everything is fine.

      Just check if while automatic import its throwing any exception like structural or value exception.

      regards Tejas..........

  • author's profile photo Former Member
    Former Member
    Posted on Jan 16, 2008 at 06:00 AM

    Hi Vikrant,

    If your mds.ini settings are right, and you are using import server.

    1. Check in Import Manager Configuration Option -->

    Checkout/Workflow. Provide the name of your workflow and save these settings in Import map.

    2. Now in Data Manager check your workflow trigger action must be Record Import.

    3. Now if you will paste a file workflow should trigger automatically.

    4. Check which user is going to approve the step. put the approver and the workflow launcher are same (means your userid) in all steps otherwise approver (if other userid) must have to approve the step before any mail come to your inbox.

    5. Put all the durations to 0 hours/days.

    6. If you do any change in mds.ini, remember to restart the MDM server.

    Please reward if found helpful.

    Regards,

    Alok

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 18, 2008 at 01:42 AM

    Hi Everyone ,

    Extremely thanks for all ur replies..

    I have done all the settings as recommeended by you all..Still Workflow doesnot trigger when the XML is in the ready folder..

    As soon as we refresh the Ready folder in FTP we see the XML is sucked in and Article ccan be seen in datamanager..and no workflow mail is triggered.

    Little bit of trouble to all of you..Can u recommend on any thread where ican see...

    1.How do i create a workflow a simple workflow?

    Smple workflow is

    Start ->Notify(by mail that the XML is ready to be checked in) -->Stop.

    2.Also may be in workflow itself iam making some mistakes in the settings?

    Can u guide me MDM Guru's

    Regards

    Vik

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Vikrant,

      Could you please check the "Mail Server= " entry in the mds.ini SAP MDM 5.5\Server configuration file is set with the value

      of your mail server name! thats also one of the factor for not receiving the mails.

      Hope this helps.

      thanks

      Alexander

      p.s.Kindly reward the points, if found helpful.

  • author's profile photo Former Member
    Former Member
    Posted on Jan 18, 2008 at 04:35 AM

    Hi Vikrant,

    I have worked on a similar scenario as yours,where my workflows steps were

    START->MATCH->APPROVE->STOP->

    I automated this workflow,whereby the import file was automatically pulled into MDM and workflow automatically launched then the matching strategy automatically executed on them.

    For this I had to:

    - Create a workflow chk if all the stencil are properly connected and then SAVE the workflow.

    -Fill in the properties of all properly,by mentioning the strategy name in the match stencil.

    -Making the trigger action as Record Import

    -In Configuration options giving the name of the workflow

    -Setting up the ini file and giving the delay time.

    If all these steps are carried out properly your workflow should work automatically fine,it worked for me

    Check to see your import server is up and running fine in the services and that your workflow is saved properly.

    Below link might help you build your workflow correctly

    https://www.sdn.sap.com/irj/sdn/advancedsearch?query=workflow&cat=sdn_all

    (Dynamism in Static Master Data Management Area - The Workflow)

    Thanks & Regards

    Simona

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.