Skip to Content
0

Resource not found in MRS 10.0 due to relevance of resource

Nov 06, 2017 at 05:07 PM

44

avatar image

Hello Experts,

When I execute T-code -> /MRSS/PLBOORGSRV, when I try to assign a resource to demand, the resource dropdown is empty.

We are upgrading our MRS add-on from 6.1 to 10. (Even Upgraded ECC 6.0 to ECC 6.0 EHP8 SPS7)

Since the value of the resources have a relevance value of F(Work center planning,Domain - /MRSS/_RESOURCE_REL) ,

due to the upgraded code(/MRSS/CL_SGE_RESOURCE_MGR->RESOURCES_GET) there is a condition to delete all the values that are not equal to A(Belongs to Organizational Unit),B(Fulfills Relevant Demand),D(Manually Added resource).

The same value F(Work center planning) is present in MRS 6.1 but the resources are available. This is all got from debugging the code.

Can you please let me know if we need to do any configurations in the new system for this and which one ?

Thank you,

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Vihari Nagella Nov 24, 2017 at 03:40 PM
0

SAP response - >

“The highlighted code is a correction : 1732335 in MRS 800 and to the upper releases. Here we introduced a condition to load only the resources which belong to the planning node.

In the given scenario, the MRS Planning node is being launched for a given demand. And unless and until you provide a planning node in resource selection or if there are any assignments for that demand, no resources will be displayed on to the UI.

This is a standard MRS behavior and is working as expected.”

Share
10 |10000 characters needed characters left characters exceeded