Skip to Content
0

MaxDB Client 7.9.09.006 > Connection failed (RTE:[1] cannot connect to server socket

Nov 06, 2017 at 03:26 PM

154

avatar image

Hi there. We have updated all our MaxDB Versions 7.9.09.005 to version

7.9.09.006 DB and Client, SAP ERP an SM 7.1 and SAP content servers. Everything was fine, only the productive contentserver client runtime is not available from the ERP System from the DB59/ or DB50! the connection test failed. Connect to database failed, rc = -10709 (Connection failed (RTE:cannot connect to server socket

I checked the sapdbmrfc from SM49/SM59. on unix host/ sdbregview / sdbverify etc.

i couldnt detect, where the error is. Who uses the newest client Version 7.9.09.006 on a contentserver/Unix also?

On our solman i had a similar problem with the J2EE Stack with that version (stack doesnt comes up) after inst. 7.9.09.006 Version. It was the runtime sapjdbc.jar file in the inst package.

a strange thing, with that package, that error i could fix,( recover of an old sapjdbc.jar) but the error here,could not fix anyway! is it the xuser, the x_server Check= ok, sdbverify =? dbmcli commands, dbm_state= online etc.*** getpath, global*** done a lot!! been at the same point, the check_db is not possible anymore (dbverify).the job could not start anymore

How i could point and locate further investigation? Whats wrong with that 06 version? The other contentserver on DEV and DEV contentserver is ok. the snote related to the change with version 7.9.09.006 points to the length of the password, could not be the error. the prod passwd is shorter.

Greets

Ralph

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Ralf Wahlen Nov 07, 2017 at 12:30 PM
0

Problem host: differnce prod to dev

/sapdb/programs/bin$ ./sdbregview -l Installation: Global /sapdb/programs Global Listener 7.9.09.06 valid 64 bit Installation Compatibility 7.9.09.06 valid 64 bit Installer 7.9.09.06 valid SAP Utilities Compatibility

7.9.09.06 valid 64 bit Installation: Legacy /sapdb/programs DB Analyzer /sapdb/programs 7.7.07.46 valid 64 bit Fastload API /sapdb/programs 7.7.07.46 valid 64 bit JDBC /sapdb/programs 7.6.06.05 valid Loader /sapdb/programs 7.7.07.46 valid 64 bit Messages /sapdb/programs MSG 0.8507 valid ODBC /sapdb/programs 7.7.07.46 valid 64 bit PCR 7300 /sapdb/programs 7.3.00.60 valid PCR 7301 /sapdb/programs 7.3.01.22 valid PCR 7500 /sapdb/programs 7.5.00.55 valid 64 bit Redist Python /sapdb/programs 7.7.07.46 valid 64 bit SQLDBC /sapdb/programs 7.7.07.46 valid 64 bit SQLDBC 76 /sapdb/programs 7.6.06.24 valid 64 bit SQLDBC 77 /sapdb/programs 7.7.07.46 valid 64 bit n.sim.to DEV

Installation: DatabaseStudio /sapdb/clients/DatabaseStudio Base 7.9.09.06 valid 64 bit Database Studio 7.9.09.06 valid Loader 7.9.09.06 valid 64 bit Redist Python 7.9.09.06 valid 64 bit SAP Utilities 7.9.09.06 valid 64 bit Server Utilities 7.9.09.06 valid 64 bit

Installation: PROD /sapdb/PROD/db Base 7.9.09.06 valid 64 bit DB Analyzer 7.9.09.06 valid 64 bit Database Kernel 7.9.09.06 valid 64 bit Fastload API 7.9.09.06 valid 64 bit JDBC 7.6.09.00 valid Loader 7.9.09.06 valid 64 bit Messages MSG 0.10302 valid ODBC 7.9.09.06 valid 64 bit Redist Python 7.9.09.06 valid 64 bit SAP Utilities 7.9.09.06 valid 64 bit SQLDBC 7.9.09.06 valid 64 bit SQLDBC 76 7.6.06.28 valid 64 bit SQLDBC 77 7.9.09.06 valid 64 bit Server Utilities 7.9.09.06 valid 64 bit

running DB59/DB50 contentserver DEV

sapdb/programs/bin$ ./sdbregview -l Installation: Global /sapdb/programs Global Listener 7.9.09.06 valid 64 bit Installation Compatibility 7.9.09.06 valid 64 bit Installer 7.9.09.06 valid SAP Utilities Compatibility 7.9.09.06 valid 64 bit

Installation: Legacy /sapdb/programs DB Analyzer /sapdb/programs 7.7.07.48 valid 64 bit Fastload API /sapdb/programs 7.7.07.48 valid 64 bit JDBC /sapdb/programs 7.6.06.05 valid Loader /sapdb/programs 7.7.07.48 valid 64 bit Messages /sapdb/programs MSG 0.8507 valid ODBC /sapdb/programs 7.7.07.48 valid 64 bit PCR 7300 /sapdb/programs 7.3.00.60 valid PCR 7301 /sapdb/programs 7.3.01.22 valid PCR 7500 /sapdb/programs 7.5.00.55 valid 64 bit Redist Python /sapdb/programs 7.7.07.48 valid 64 bit SQLDBC /sapdb/programs 7.7.07.48 valid 64 bit SQLDBC 76 /sapdb/programs 7.6.06.27 valid 64 bit SQLDBC 77 /sapdb/programs 7.7.07.48 valid 64 bit both not similar to PROD

Installation: DatabaseStudio /sapdb/clients/DatabaseStudio similar to prod!

Base 7.9.09.06 valid 64 bit Database Studio 7.9.09.06 valid Loader 7.9.09.06 valid 64 bit Redist Python 7.9.09.06 valid 64 bit SAP Utilities 7.9.09.06 valid 64 bit Server Utilities 7.9.09.06 valid 64 bit Installation: DEV /sapdb/DEV/db Base 7.9.09.06 valid 64 bit DB Analyzer 7.9.09.06 valid 64 bit Database Kernel 7.9.09.06 valid 64 bit Fastload API 7.9.09.06 valid 64 bit JDBC 7.6.09.00 valid Loader 7.9.09.06 valid 64 bit Messages MSG 0.10302 valid ODBC 7.9.09.06 valid 64 bit Redist Python 7.9.09.06 valid 64 bit SAP Utilities 7.9.09.06 valid 64 bit SQLDBC 7.9.09.06 valid 64 bit SQLDBC 76 7.6.06.28 valid 64 bit SQLDBC 77 7.9.09.06 valid 64 bit Server Utilities 7.9.09.06 valid 64 bit


Share
10 |10000 characters needed characters left characters exceeded