Skip to Content
0

SOAP Lookup udf not working

Oct 17, 2016 at 02:26 PM

121

avatar image
Former Member

Hello,

I have followed below blog and successfully deployed the code on PO server.

How to persist custome data in sap pi

I am able to do insert, update, delete and fetch operations on this custome table via ICO and wsnavigator. However if i try to do the same via SOAP Lookup udf in message mapping then i dont receive any response and receiver soap channel shows error as "Error in response". Attach herewith error log for more information.

Can anyone please suggest.

error.txt (5.4 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Raghuraman S Oct 18, 2016 at 03:37 AM
0

Hello Mandar,

check and ensure any Soap action need to be maintained in the soap channel.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Oct 18, 2016 at 07:32 AM
0

Hello Raghuraman

Thanks for your reply.

Soap action is maintained in the soap channel.

Share
10 |10000 characters needed characters left characters exceeded
Evgeniy Kolmakov Oct 21, 2016 at 02:58 AM
0

Hi Mandar!

Wouldn't you please provide your UDF code?

Regards, Evgeniy.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Oct 28, 2016 at 11:31 AM
0

Hello Evgeniy,

The format of the soap xml was not correct. It is resolved now. Anyways thanks for your help.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Can you explain more? what was the problem and how did you resolved and make your answer as the correct answer so that it will be helpful for others in future.

0
avatar image
Former Member Oct 28, 2016 at 02:21 PM
0

Hello Praveen,

In the udf, the soap xml format was not correct. I havent added the namespace for the root node while building the xml and due to which PI was not able to find the correct soap action at runtime.

For ex:

The root node was: <po:addticket>, instead it should be like: <po:addticket xmlns:po="http://po.sap.com/">

I hope it is clear now.

Regards,

Mandar

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

You can mark this as correct answer so that it can appear on top instead of the bottom, you can find the option when you click on actions (Actions->Correct Answer)

0