Skip to Content

AIX 5.3 - SAPInst won't start - "child has signaled an exec err"

Hi,

I'm trying to patch TREX 7.0 on AIX 5.3 but I can't get SAPInst to start... the GUI gives the error "SAPInst is not available on localhost:21200" (same when I use the hostname).

The output from sapinst is:

[==============================] - extracting... done!

Starting GuiServer using:

/usr/java14_64/bin/java -cp /tmp/sapinst_exe.2511080.1200380799/JAR/instgui.jar:/tmp/sapinst_exe.2511080.1200380799/JAR/inqmyxml.jar -Djava.security.egd=file:/dev/urandom SDTServer config=jar:sdtserver.xml guiport=21212 sapinsthost=localhost sapinstport=21200 guistart=true

iauxsysex.c:317: child /tmp/sapinst_exe.2511080.1200380799/sapinst (pid 4161570) has crashed. Executable directory is /tmp/sapinst_exe.2511080.1200380799. Contact Support.

iaextract.c:814: child has signaled an exec error. Keeping directory /tmp/sapinst_exe.2511080.1200380799

I have tried starting "sapinst -nogui" and then "startInstGui.sh" separately but no success.

I can't start "sapinst -nogui" as root at all, there's no errors, it just doesn't do anything! As <SID>adm, it looks like it starts but then the GUI says there is no sapinst running.

I've set the JAVA_HOME, SAPINST_JRE_HOME and PATH envs and my limits are:

time(seconds) unlimited

file(blocks) unlimited

data(kbytes) unlimited

stack(kbytes) unlimited

memory(kbytes) unlimited

coredump(blocks) 2097151

nofiles(descriptors) 2000

The strange thing is I installed TREX as root the other day and everything was fine, but today when I came to install the patch I just can't get it to start, or even get any meaningful error messages... Any help would be GREATLY appreciated.

Many thanks

Jane

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jan 15, 2008 at 07:24 AM

    P.S. I tried running another version of sapinst (from NETWEAVER 2004S install DVDs) and got exactly the same thing.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi David,

      Thank you for your suggestions. I had already checked the limits and /tmp space.

      I don't know what caused the problem, but I patched SAPINST using the latest version from SAP MarketPlace (ref SAP note 929929) and that seems to have sorted it. I can now run sapinst and continue the installation.

      Regards

      Jane