Skip to Content
0

Installation XS fails / hdbmodify hdb_modify_addlocalroles Directory '' does not exist

Nov 05, 2017 at 03:06 PM

73

avatar image

Hi,

I have some trouble reinstalling HANA XS Advanced Runtime. After some back and forth I managed to uninstall the failed installation and start from scratch.

Unfortunately I get this error when the xs_worker is about to get added.

SAP HANA Lifecycle Management - hdbmodify_addlocalroles  2.2.25 
*************************************************************** 
Reconfiguring SAP HANA system failed!
Running in batch mode 
Directory '' does not exist 
Program terminated with exit code 1

I got the same error as I wanted to remove the xs_worker for the uninstall. Here I used

hdbnsutil -removeHostRole <HOST> --role=xs_worker

How can I get rid of this "Directory '' does not exist" error ?

Regards

Volker

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Tobias Lejczyk
Nov 30, 2017 at 03:10 PM
0

Hi Volker,

I just ran into the same problem here...
The trick is:
add "--sapinst=/hana/shared" to the commandline.

I activated the Installer Trace with the environment Variable
export HDB_INSTALLER_TRACE_FILE=<file>
(pointing it to /tmp/hdbmodify.trc).

Then I ran the command again.
In the tracefile it told me that the variable "sapmnt" was empty. This came directly before the Error message.

When I searched for sapmnt in my install-directory, I saw, that most of the commands are called with "--sapmnt=/hana/shared". So I added it to the commandline and the error was gone.

Hope this helps.

Best regards,
Tobias

Share
10 |10000 characters needed characters left characters exceeded