Skip to Content
avatar image
Former Member

Alert Configuration

Hi All,

We are planning to work on an scenario to raise an alert whenever an error occurs in moni. I have done the basic configuration settings using Michal Krawczyk's blog:

/people/michal.krawczyk2/blog/2005/09/09/xi-alerts--step-by-step

I have done my configuration till step 4, but when I do step 5 in RWB I am getting an error message

"404 Not Found

The requested resource does not exist.

Details: Go to main page of this application!"

I am not sure, how to resolve this, Also FYI in using PI7.0 and I have referred few documents for XI.3.0 but I couldn't get any clues. So provide me with a solution with respect to 7.0.

Regards,

Nithiyanandam

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 14, 2008 at 09:02 AM

    Hi,

    This error occurs when you do not have a rights to create the alert rule through RWB.

    Check the rights on the users which is used for configuration.

    The following predefined user roles are available for customizing and administration:

    • SAP_BC_ALM_CUST for customizing authorization.

    • SAP_BC_ALM_ADMIN for administration authorization. The administrator has the authorization for all activities. He or she can also read and confirm alerts for other users. In addition, the administrator can execute report RSALRTPROC to delete, escalate, and deliver alerts as well as to delete logs.

    • For the sending of alerts via external communication methods (e-mail, sms, fax) and for inbound processing, an RFC user has to be created on the central alert server with the role SAP_BC_ALM_ALERT_USER. The authorization objects contained in this role are S_OC_SEND and S_RFC.

    • Accessing alert inbox the userid has to have the role SAP_XI_MONITOR.

    • SAP_ALM_ADMINISTRATOR - Alert Management Administrator Give this rights

    Refer the SAP_XI_ADMI topic and see the roles.

    http://www.erpgenie.com/sap/netweaver/xi/xiauthorizations.htm

    Refer link for user roles: http://help.sap.com/saphelp_nw2004s/helpdata/en/74/03b140ade49c2ae10000000a155106/content.htm

    Thnx

    Chirag

    Edited by: chirag Gohil on Jan 14, 2008 2:38 PM

    Edited by: chirag Gohil on Jan 14, 2008 2:39 PM

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 14, 2008 at 09:13 AM

    Error: 404 Not Found

    Description: The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent. The 410 (Gone) status code SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding address. This status code is commonly used when the server does not wish to reveal exactly why the request has been refused, or when no other response is applicable.

    Possible Tips:- for HTTP_RESP_STATUS_CODE_NOT_OK 404

    • 404 is an HTTP response code that indicates that the resource in question couldn't be found. Usually this is due to an incorrect URL, so it is better to cross check all URLs. Check pipeline URL in the SLD in the business system of the Integration Server For this go to SLD->Business System-><yourIntegrtaion Server>->Pipeline URL: It should be like this http://<host>:<port>/sap/xi/engine?type=entry Where host is the host name of the Integration Server and port is the HTTP(8xxx) port. To verify this in Integration Server you can do like this. Go to SXMB_ADM->Integration Engine Configuration->Choose Edit from Menu -> Change Global Configuration Data to switch to change mode. Then select System Landscape - Load Configuration. (This is not required always)

    • Check that the port really is the ICM HTTP Port and not the J2EE port i.e SMICM then menu GOTO --> SERVICES and check the port number for HTTP. It should be HTTP port

    • If the error is Page cannot be displayed, cannot find server in https configurations Check and correct the SSL configuration for the ABAP and the J2EE side of the system

    • If the error is because of integration server when using Proxy communications then check these. i.e SXMB_ADM->Integration Engine Configuration->Corresponding Integration Server enrty should be dest://<Http Integration server-Destination> Where < Http Integration server -Destination > is the RFC destination (SM59) of type HTTP connection (type H) to the Integration Server. In this case, host name, port, and path prefix are saved in the RFC destination.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 14, 2008 at 09:21 AM

    Hi,

    Are you activated the ITS service?

    Go to SICF TA and do it.

    Regards

    Ivá

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 14, 2008 at 10:49 AM

    Hi,

    Check this SAP Note at https://service.sap.com/notes

    750287 - XI 3.0 Runtime Workbench: Alert configuration does not start

    IF you dont have access to market place let us know.

    Regards,

    Sumit

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 14, 2008 at 02:23 PM

    Hi Nithiya,

    Just follow the following steps...i am sure you handle it by urself..

    1.Go to exchange profile

    http://<IP>:<Port>/exchangeProfile/index.html

    Then RuntimeWorkbench -> com.sap.aii.rwb.server.centralmonitoring.r3.ashost = xiserver.bsp.incos

    ->com.sap.aii.rwb.server.centralmonitoring..httpport = 8000

    2. Reinitialize the RWB service by : http://xiserver:50000/rwb/rtc?op=init

    3. RZ10 - Make an entry for /icm/host_name_full

    let me know for any doubts..

    Regards,

    Add comment
    10|10000 characters needed characters exceeded