Skip to Content
0

Create model on file and split field with content "2017-10-29T00:25:19"

Nov 02, 2017 at 01:35 PM

61

avatar image
Former Member

Hi experts

I am trying to create a model that contain a field with the content "2017-10-29T00:25:19". As you can see it is a merge of the date and time joined by the letter "T". What I want to do is to split the column into two columns (a date and a time column). If I use the spit function I just get two empty columns. I am not sure but I assume the reason is that the column has the Data type Date. Under Modeling I changed the type from Time to Dimension but the Data type is still Date. How do I manage to spit the column "2017-10-29T00:25:19" to two columns where one of them are is a date with type date?

Kind regards

Erik

before.png (82.0 kB)
split-1.png (24.2 kB)
split-2.png (37.9 kB)
10 |10000 characters needed characters left characters exceeded

Hi Erik,

The two columns you see on split-1.png are preview the data only.
Are you also getting two empty columns after pressing enter/i.e submitting the split? You should be able to go back using the Undo button to revert changes if anything goes wrong.

If so could you please let me know how does the splitting work if you :

1. Change the Time type to Dimension format first
2. Do the splitting on "T" and let me know the result.

The dataset looks quite big (does it come from SQL DB/flat file or something else?)
so I was wondering if you are facing the same with smaller set of data?

I look forward to hear from you.

Best Regards, Mark

0
Former Member

Hi Mark

The data set is a csv file that is 8 Mb big. I have tried to set the column to Dimension first and then do the split but the same error occur. The "Data type" is set to Date regardless if the Modelling Type is Dimension or Time.... Strange that SAC are not able to do this simple split.

Kind regards

Erik

0

Hi Eric,

I have tried with a small dataset having only 8-9 rows based on .xlsx, where splitting did work.

It looks like we have to investigate this case further internally. In order to do that our experts have to get in touch with you.

I would recommend you to open a support incident using component LOD-ANA-BI as we may need to perform further tests to provide a solution.

Best Regards, Mark

0
Former Member
Mark Fodor

Hi Mark

This has been reported as an error by SAP Support and it should be fixed on the next releases.

Erik

1
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Mark Fodor
Nov 14, 2017 at 09:59 PM
0

Hi Erik, Thank you for reporting this to SAP Support.

We've created a Knowledge Base Article about the behavior which could be found under KBA number: 2561182.

Development Team is investigating the reported defect and KBA will be updated with the feedback shortly including the targeted wave with the fix .

Best Regards, Mark

Share
10 |10000 characters needed characters left characters exceeded