Skip to Content
avatar image
Former Member

BPC 10.1 : Export and Import journals not working properly

Hello BPC experts,

I have 1 question for exporting journals and another one for importing. I have followed the guide Journal guide for both functionalities but it is not working. I am using 2 systems : the 1st in 10.1 (which does not work) and the 2nd in 10.0 (which works fine).

BPC 10.1 is integrated with BW 7.5.

1) Export

Main issue here is that when I launch the package, it gives the status "Succeeded" but it actually only exports the headers but no journal. I have posted 2 journals in the web client. Since there is no selection/filter beforehand, those 2 journals should be displayed.

I tried to export on 2nd customer system (version is 10.0) and it works fine. I do not see any notable differences in the settings between both (SPRO global settings, environment and models are the same; Journal features in the web client have nothing special, Reopening rules are empty). Below is what I get from the 1st customer system (only header) :

So the process to export I followed is :

Create an non-empty output file called "TEST_TEST.txt" > Save in local file > Convert to TEST_TEST.JRN > Upload into BPC > Launch package Export > Choose TEST_TEST.JRN > Finish

So why is there no data when processing the package export journal ? Anything I have done that could be wrong ? This would be strange since the 2nd system in 10.0 properly works.

2) Import (restore)

For this part, I have checked and

I got this error message (like the second url) :

I understand that i firstly need to export journals to get the right format/structure for the importing file. Besides, I also should avoid using CSV format from excel when modifying its content. Since exporting journals still gives me the structure/format (even if empty), i filled this file (in .txt format) by using the 2nd system data (of course by paying attention to headers and adapting dimensions, user name, etc.). Once again, it works on the 2nd system but it does not work for the 1st.

The process used to import :

Export journals into a .JRN file to get structure/format (but no journal data because of the 1st issue) > download file to local > change the format into .TXT > fill the data by following the header order > Save and change back to .JRN > Upload > Launch Import journal package.

What could go wrong for this part ? Here is the file used to import : test-restore-journals.txt

Both dates are not filled as I was able to import journals without date in 2nd system. Of course, I also tried to fill those dates with 20200000000000 for instance (this data comes from the 2nd system).

Please, any advice is welcomed !

Thank you in advance,


Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Nov 08, 2017 at 10:59 AM

    After resetting the note 2348434 and reimplementing this note, the issue disappeared but it also solved the problem about importing journals !

    So as a summary for this post :

    Export solution : sap note 2371964

    Import solution : sap note 2348434 (solving actually a journal template issue)

    Thank you Vadim for your help.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 02, 2017 at 06:11 PM

    Just tested using BPC on BW 750 SP 06 with the copy of ENVIRONMENTSHELL!

    In the Consolidation model I have posted single journal and successfully exported it using DM package:


    Package:     Export Journals
    Environment:    SHELLTEST
    model:    Consolidation
    /CPMB/MODIFY completed in 0 seconds
    /CPMB/EXPORT_JOURNAL completed in 0 seconds
    /CPMB/CLEAR completed in 0 seconds
    Request Time:    2017-11-02 18:05:39
    Start   Time:    2017-11-02 18:05:39
    End     Time:    2017-11-02 18:05:39
    Total   Time:    00:00:00
    model: Consolidation. Package status: SUCCESS

    Resulting file:

    SHELLTEST,Consolidation,000001,0000000001,Test,KALININV_EXT,20171102175730 ,KALININV_EXT,20171102175739 ,P,-1,,-1,-1,,X,,,,Input,Actual,EUR,S_None,2017.01,DE,PL010,Balance,ThirdParty,00000001,150.0000000,,SalesT1
    SHELLTEST,Consolidation,000001,0000000001,Test,KALININV_EXT,20171102175730 ,KALININV_EXT,20171102175739 ,P,-1,,-1,-1,,X,,,,Input,Actual,EUR,S_None,2017.01,DE,PL110,Balance,ThirdParty,00000002,,150.0000000,PurchT1

    No surprise...

    Check the model and environment used...

    webjour.png (131.2 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 03, 2017 at 09:52 AM

    I found the solution for the exporting journals issue :

    Implement SNOTE 2371964 - "EXPORT_JOURNAL" can't get journal content

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Yes sorry my bad, I was confused because since BPC is implemented with BW 7.5 I couldn't see BPC component anymore but I should just give the BW SP in this case (SP 05).

  • avatar image
    Former Member
    Nov 03, 2017 at 10:32 AM

    Export is now working fine but Import is still an issue.

    I did the following : Export journals to "REIMPORT.JRN" > Unpost journal on web client (there is only one journal)> Clear journal table (with package) > Restore journal with "REIMPORT.JRN"

    It fails with the same error message than then screenshot I provided in my first message.

    reimport.jrn file wasn't modified and looks like this : reimport.txt

    It can't be a SP issue this time ?

    reimport.txt (472 B)
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 08, 2017 at 09:48 AM

    I don't know if I should open another post for the following issue :

    While checking for any possible solution for importing journals, I found another (related ?) problem : when I try to change the secured dimension of the model "Consolidation", it gives the message "Try to update a template that does not exist".

    The sap note 2348434 provides a solution to this specific issue.

    However, after implementing this note, I get a new error message when trying to open a Model from web client : <HTML><HEAD> <TITLE>500 SAP Internal Server Error</TITLE> </HEAD><BODY> <H1>500 SAP Internal Server Error</H1> ERROR: Syntax error in program CL_UJJ_JRN_MGR================CP . (termination: RABAX_STATE)<P> </BODY></HTML>

    I can't run or make any change on DM package anymore. I cannot find any related sap note for that part.

    What could be the solution ? (I cannot unfortunately update the current version BW 7.5 SP05 to higher support package)

    EDIT : I cannot open a model but reports can still be run. There is a journal entry when I implemented the note. I cannot delete it anymore with package "clear journal".

    Add comment
    10|10000 characters needed characters exceeded