Skip to Content
author's profile photo Former Member
Former Member

unable to generate syncbos

Hi

After uploading the standard MAM30 syncbos from MEREP_MIG system is not generating syncbos in MEREP_sbuilder , it syas that Bos are already been published while in MEREP_PD i see them in not generated and not able to enable them .

Is there any way to delete the standard bo uploaded and reimport import the .txt file .

Did any one face this problem earlier ?

Regards

siddhartha

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 17, 2008 at 01:07 AM

    Hi Siddhartha,

    There is no official way to remove standard SyncBos once they have been uploaded in the system.

    Normally, when you need to make an upgrade a new definition file whould be uploaded and existing SyncBos updated.

    But, if you have made some kind of mistake, system is really screwed you can delete SyncBos - run Delete functionlaity in debug mode and overwrite system authorisations while executing it. You will have to find first the position in a code where to do this.

    This is unofficial but if you desperately need to delete, this is the only way. And I know it is possible because I have done it (a while ago, so I don't remember a code line where you need to overwrite, you'll have to find it yourself).

    Regards,

    Larissa Limarova

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 09, 2008 at 09:36 AM

    Hi,

    I think you pressed the published button as you exported the SyncBO form the old system in MEREP_MIG. Published BOs have problems while generating them after import. So do not use the published button at export!

    Anyway, you can always reimport SyncBO definitions with the tool MEREP_MIG. The hard way is to delete the BO in MEREP_SBUILDER and import it again voia MEREP_MIG.

    Hope this helps!

    Regards,

    Oliver

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      oh - yes - SAP standard BOs - once in the system.....

      Ok, in the future never press this Publish button. 😊

      Ok, I have done it in my system at the moment and so I will tell you what I did to get a working system again - if this does not help we should talk in depth. The search below> Yes I know you are using SAP standard, but searching for Z.... is correct, because this method is created by MEREP?SBUILDER while generating the BO / and this method still exists in your case!

      - I published a BO (this is already done by you)

      - I went to SE80. There I selected "Function Group"

      - I searched for "Z_MEREP_GEN*"

      - I deleted this Group completely for the BO I wanted to regenerate

      - I imported the BO definition again using MEREP_MIG

      - Voila, I was able to work with the BO again and for example generate it

      As I said, this I did that moment!

      Oh yes, if this error occures again after import - use another file to import!

      Hope it helps.

      Regards,

      Oliver

      Edited by: Oliver Kaluscha on Jan 11, 2008 8:35 AM

      Edited by: Oliver Kaluscha on Jan 11, 2008 4:37 PM

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.