Skip to Content
author's profile photo Former Member
Former Member

Recording malfunction in LSMW

Hi wizards,

I am facing a very peculiar problem while trying to upload material master using batch input method. During recording, I have selected all the MRP views (1-4) and entering data in the corresponding fields of the views, but after completion of recording, I found that only selection of MRP 1 and 4 views are getting recorded, while that of MRP 2 and 3 views are not getting recorded, but data entry in all the MRP views are getting recorded. As a result, while uploading the file, there is problem in runnning the batch input session. Please help.

Thanks and regards,

Abhik

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Jan 09, 2008 at 03:05 AM

    Hi,

    Check for those materials where update failed, has the corresponding views ( MRP2 / MRP3 ) are opened up in the respective plant with MM01 transaction. If the view is not opened up in MM01 transaction for a plant, there is no question of update of fields on those views.

    And another point is, Recording some updates for Material Master by BDC/LSMW ( Batch Input ) is not suitable. I suggest you either use following:

    *- By LSMW
    Objekt               0020   Materialstamm  
    Methode              0000   (Keine Auswahl)
    Programmname         RMDATIND              
    Programmtyp          D   Direct-Input      
    

    BAPI: BAPI_MATERIAL_SAVEDATA

    Best Regards, Murugesh

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Murugesh Arcot

      Hi Murugesh,

      the checkboxes I am talking about are the ones for selecting views (MRP view, basic data view etc.). Even though I am selecting the views initially, after the recording is over I find that the selected views have become unchecked.

      I have never used the direct input method. If u have any document about how to use the direct input method then please can you forward the same to me at guddagudboy@gmail.com?

      Thanks and regards,

      Abhik

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.