Skip to Content

R3load ttaking too much time when table REPOSRC is loaded

Hello,

I am installing the SAP ECC 6.0 SR2 on SUN Solaris 10 on DB2 V9.1. 17 jobs of the 19 have been completed in ABAP Import phase but it is taking too much time while doing this SAPSSEXC. It is running aroung 10 hours. There is no error is giving. So I have canceled the SAP Installation. After that I have started through manual OS command

/sapmnt/<SID>/exe/R3load -dbcodepage 4102 -i /<instdir>/SAPSSEXC.cmd -l /<instdir>/SAPSSEXC.log -stop_on_error -merge_bck

It is also running around 9 hours. I do not why it is happening and when it will be completed.

Can you help me what will check for doing this job fast or can help me how to resolve this issue?

I have checked these SAP notes 454368 and 455195

If i change any DB2 parameter, I have to restart the DB2 Database. What will I do? I can not understand what to do now.

Please help me ASAP.

Thanks

Gautam Poddar

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 08, 2008 at 12:58 PM

    Hello,

    running the R3load import step manually you might try to add the option

    -loadprocedure fast LOAD

    Pay attention to write the LOAD in capital letters!

    This will invoke the LOAD-API whenever possible.

    This should save some time on "normal" tables without LOB-columns.

    For your table REPOSRC that has a BLOB column the LOAD-API will not be taken.

    So I am sorry this will not work for your special case.

    (Thanks for the hint to Frank-Martin Haas)

    Kind regards

    Waldemar Gaida

    Edited by: Waldemar Gaida on Jan 10, 2008 8:26 AM

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 08, 2008 at 02:36 PM

    I had a similar issue. What I was seeing was a very high cpu load of db2agent (<SID>). I switched on STMM (using Note 899322 - DB6: DB2 9.1 Standard Parameter Settings), restarted the database and the loading of that table was finished in under an hour.

    Markus

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.