Skip to Content
avatar image
Former Member

SapGUI 710 is not working fine in Windows Vista

Hi all,

I need to use SAPGUI 710 on Windows Vista 😔

I had done it and updated to version 39 after read in this forums that is required a patch for use under this system. But it keeps not working. The error message is:

WSATYPE_NOT_FOUND

The specified class not found

RELEASE 710

COMPONENT NI (network interface)

VERSION 39

RC -1

MODULE ninti.c

LINE 938

DETAIL NiPGetServByName: 'sapgw00' not found

SYSTEM CALL getaddrinfo

ERRNO 10109

ERRNO TEXT WSATYPE_NOT_FOUND: The specified class was not found.

COUNTER 1

I checked at: C:\WINDOWS\system32\drivers\etc\services and 'sapgw00' is added as entry.

Thanks in advance for your help. Best regards.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Jan 07, 2008 at 01:58 PM

    if sapgw00 is the last line in the file, make sure you add an additional line after it.

    Markus

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 08, 2008 at 09:21 AM

    Hi

    Thanks all for your interest. The problem is solved creating a services file like in Windows XP file, with no '.ppp' and not extension.

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 18, 2008 at 11:26 AM

    Hi Federico

    I think that your problem will solved doing the following:

    1) Open the "REGEDIT"

    2) Go to:

    HKLM\System\CurrentControlSet\Services\TCPIP\Parameters\DatabasePath

    3) Rename DatabasePath to Databasepathold

    4) Create an Expandable-String Value with the same values that Databasepathold, for example

    Databasepath

    value= %SystemRoot%\System32\drivers\etc

    Hope this help you

    Add comment
    10|10000 characters needed characters exceeded

    • > DETAIL NiPGetServByName: 'sapdp00' not found

      > SYSTEM CALL getaddrinfo

      > ERRNO 10109

      > ERRNO TEXT WSATYPE_NOT_FOUND: The specified class was not found.

      > COUNTER 1

      > sapdp00 3200/tcp

      This is all really strange.

      The error message WSATYPE_NOT_FOUND means, that the specified service name (sapdp00) is not supported for the socket type.

      Do you have IPv6 activated on that network interface?

      Markus

  • avatar image
    Former Member
    Dec 17, 2008 at 12:31 PM

    Hi all many of us are saying SAP will not support on Windows Vista.But here u r discussing about SAP on windows vista.Can you guys help out me .Even I have Vista and planning to install SAP.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi all many of us are saying SAP will not support on Windows Vista.

      nobody is saying that.

      We are using Vista on many client machines and it works.

      But here u r discussing about SAP on windows vista.Can you guys help out me .Even I have Vista and planning to install SAP.

      Can you please tell me what you mean with "planning to install SAP"?

      The company SAP has > 200 products which can be installed on various operating systems and databases. It´s right that neither an ERP 6.0 nor an EP 7.0 server will run on Vista.

      Markus