Skip to Content
author's profile photo Former Member
Former Member

Missing messages with JDBC adapter

Hi ,

I have a file to JDBC adapter scenario. In the JDBC adapter there are multiple table updates and also executes a stored procedure.

In production I am missing file's and this has happenned on 2 different occassions. The message has come through the file adapter and SXMB_MONI is fine with a success flag. However there is no trace of the file in the SQL database.

This happens when 2 or 3 files come in at the same time. When the file is re-dropped it processes without any issues.

I have tried to re-create this issue in QA with processing 60 files at the same time and was not able to re-create this error.

There is a deadlock error but it resolves without any issue.

Any help is greatly appreciated.

Joe Vellaiparambil

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 05, 2008 at 12:21 PM

    Also,

    if you want to see the sql string xi has generated, you can put in your jdbc com. channel on advanced mode the parameter "logSQLStatement" with value "true". Then you can check if there is something wrong in sql string.

    regars

    roberti.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 04, 2008 at 10:34 PM

    Hi,

    > However there is no trace of the file in the SQL database.

    I faced the same issue. This is due to Content in XI/PI Database.

    Shall I know what SP level ?

    We can resolve it by deploying a SDA file.

    Regards

    Agasthuri Doss

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Can you clarify what you mean by content in the XI/PI database and how that affects this.

      Deploying an sda...does the archive have an ear that has a fix for some of the issues..i am assuming that is the case..so in essense a custom

      extension to a module....

      Regards

      Ravi Raman

  • author's profile photo Former Member
    Former Member
    Posted on Jan 05, 2008 at 12:18 PM

    To check what is happening you need to go to runtime workbench, component monitoring, comunication channel monitoring, and search for your communication channel. There you will see why your message was not posted on the database.

    regards.

    roberti

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.