Skip to Content
avatar image
Former Member

Issued/failed restore of BO Servers Configurations via CCM

Environment:

WinServer 2012 R2
BI4.2 SP3 FP0
HANA SPS12

Tomcat 8
Internet Explorer 11

Description:
We received the following failed message during restore of BO server configuration process.

restore_20171027_115844.log ---
"BI4NODE1.ExplorerExplorationServer1 Disregarding 0 non-Server Intelligence objects that were imported from O:\Post_Restore\BI404_SrvrConfig_BckUp_2017_10_19.biar. Restoring 104 infoobjects... Restoring 28 infoobjects... Restoring 482 infoobjects... Default object fragment failed. Default Object fragment from file ServerIntelligence_Install_BI4NODE1_Extensions_NCS_dfo_frag.xml failed to be applied to object (Name: BI4NODE1; CUID: AfU6QSnKouJJleW3n1_Fr6U). Check assert log for details. (FWB 00075) Stopping CMS... Restore operation failed. "

CMS_8444_2017_10_27_16_02_03_519_trace.glf ---
".\deploy.cpp:1097:-: TraceLog message 17
|f43e6144-3199-32f4-683d-9ca883a48691|2017 10 27 12:09:34:133|-0400|Error| |>>|E| |CMS| 8444|13184|| |5|0|1|0|BIPSDK.InternalInfoStore:commit|GFSCDVDWBI404:4556:1.4808:1|BIPSDK.InternalInfoStore:commit|GFSCDVDWBI404:4556:1.4808:1|CMS.commitEx4|localhost:8444:13184.689:1|Cl9g0FPYrkWhk5PN8Hvpnvg12c8|||||||||||assert failure: (.\deploy.cpp:1097). (false : Update of SI_CONFIG.1 from file ServerIntelligence_Install_BI4NODE1_Extensions_NCS_dfo_frag.xml to target SI_CONFIG.18 failed. The payload property is owned by another file, ServerIntelligence_Install1_BI4NODE1_Extensions_NCS_dfo_frag.xml.). "

Steps to reproduce:

1. Node1's CMS is restored from PROD with PROD BO servers name and configurations
2. Stop Node1's SIA
3. Initiate restore Server Configuration process with using DEV BO server configuration .biar from CCM
4. Enter HANA connection info, DB key, location of .biar
5. Monitor restore process: reading of .biar file then implement of .biar file
6. Restore process is ~90% completed then message of failed bo restore appeared.
7. Check restore log:restore_20171027_115844.log ---
"BI4NODE1.ExplorerExplorationServer1 Disregarding 0 non-Server Intelligence objects that were imported from O:\Post_Restore\BI404_SrvrConfig_BckUp_2017_10_19.biar. Restoring 104 infoobjects... Restoring 28 infoobjects... Restoring 482 infoobjects... Default object fragment failed. Default Object fragment from file ServerIntelligence_Install_BI4NODE1_Extensions_NCS_dfo_frag.xml failed to be applied to object (Name: BI4NODE1; CUID: AfU6QSnKouJJleW3n1_Fr6U). Check assert log for details. (FWB 00075) Stopping CMS... Restore operation failed.

Found KBA : 1275068 and followed the instructed steps. That failed too.

Next, we tried to create secondary SIA however it also failed with a different error in the logs: "Unexpected duplicate node found.....stopping CMS....AddNode abored due to errors."

The third scenario we tired was to delete the SIA and add a new node with default servers. That failed too with errors: "The root server reported an error Initialization Failure. (Reason: Missing critical system object type. Kind: LicenseRestriction. (FWB 00037)Missing critical system object type. Kind: LicenseRestriction. (FWB 00037) Unable to find LicenseRestriction kind."

Now, we do not have any SIA and are not unable to create, recreate, add with out servers, or add node with CMS, etc. PLEASE HELP or advise.

Thank you ahead and apprication on guidence.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Nov 01, 2017 at 05:42 PM

    Sounds like you need to open support incident with SAP.

    As to the issue - not clear what and where you're restoring. Please note - if the server you're restoring to another server is running - this shouldn't work. The original server should be down to avoid name duplications, network issues and CMS corruptions.

    Add comment
    10|10000 characters needed characters exceeded