Skip to Content
0
Former Member
Jan 03, 2008 at 01:14 PM

DB Connect LINUX_X64 to Solaris SPARC

51 Views

Hi,

I have successfully installed an application server on LINUX X86_64, but I can't start the instance because no database connect to database server on SOLARIS SPARC 64 bit is possible. R3trans -d -v finished with return code 12:

4 ETW000 R3trans version 6.13 (release 640 - 10.07.07 - 13:48:00).

4 ETW000 ===============================================

4 ETW000

4 ETW000 date&time : 03.01.2008 - 12:52:21

4 ETW000 control file: <no ctrlfile>

4 ETW000 R3trans was called as follows: R3trans -d -v

4 ETW000 trace at level 2 opened for a given file pointer

4 ETW000 [dev trc ,00000] Thu Jan 3 12:52:21 2008 188 0.000188

4 ETW000 [dev trc ,00000] db_con_init called 18 0.000206

4 ETW000 [dev trc ,00000] create_con (con_name=R/3) 50 0.000256

4 ETW000 [dev trc ,00000] Loading DB library '/usr/sap/PRD/SYS/exe/run/dboraslib.so' ...

4 ETW000 38 0.000294

4 ETW000 [dev trc ,00000] load shared library (/usr/sap/PRD/SYS/exe/run/dboraslib.so), hdl 0

4 ETW000 14346 0.014640

4 ETW000 [dev trc ,00000] Library '/usr/sap/PRD/SYS/exe/run/dboraslib.so' loaded

4 ETW000 14 0.014654

4 ETW000 [dev trc ,00000] function DbSlExpFuns loaded from library /usr/sap/PRD/SYS/exe/run/dboraslib.so

4 ETW000 32 0.014686

4 ETW000 [dev trc ,00000] Version of '/usr/sap/PRD/SYS/exe/run/dboraslib.so' is "640.00", patchlevel (0.175)

4 ETW000 101 0.014787

4 ETW000 [dev trc ,00000] function dsql_db_init loaded from library /usr/sap/PRD/SYS/exe/run/dboraslib.so

4 ETW000 12 0.014799

4 ETW000 [dev trc ,00000] function dbdd_exp_funs loaded from library /usr/sap/PRD/SYS/exe/run/dboraslib.so

4 ETW000 37 0.014836

4 ETW000 [dev trc ,00000] New connection 0 created 30 0.014866

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = -000000001 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 2

55, con_opt = 255, occ = NO

4 ETW000 15 0.014881

4 ETW000 [dev trc ,00000] db_con_connect (con_name=R/3) 41 0.014922

4 ETW000 [dev trc ,00000] find_con_by_name found the following connection for reuse:

4 ETW000 14 0.014936

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = 000000000 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 25

5, con_opt = 255, occ = NO

4 ETW000 11 0.014947

4 ETW000 [dev trc ,00000] Got ORACLE_HOME=/oracle/PRD/920_64 from environment

4 ETW000 2113 0.017060

4 ETW000 [dev trc ,00000] -->oci_initialize (con_hdl=0) 45 0.017105

4 ETW000 [dev trc ,00000] got NLS_LANG='AMERICAN_AMERICA.WE8DEC' from environment

4 ETW000 11 0.017116

4 ETW000 [dev trc ,00000] Client NLS settings: AMERICAN_AMERICA.WE8DEC 16753 0.033869

4 ETW000 [dev trc ,00000] Logon as OPS$-user to get SAPR3's password 35 0.033904

4 ETW000 [dev trc ,00000] Connecting as /@PRD on connection 0 (nls_hdl 0) ... (dbsl 640 250407)

4 ETW000 18 0.033922

4 ETW000 [dev trc ,00000] Nls CharacterSet NationalCharSet C EnvHp ErrHp ErrHpBatch

4 ETW000 19 0.033941

4 ETW000 [dev trc ,00000] 0 WE8DEC 1 0x1443790 0x144ca20 0x144c3b8

4 ETW000 29 0.033970

4 ETW000 [dev trc ,00000] Allocating service context handle for con_hdl=0 25 0.033995

4 ETW000 [dev trc ,00000] Allocating server context handle 13 0.034008

4 ETW000 [dev trc ,00000] Attaching to DB Server PRD (con_hdl=0,svchp=0x144c2e8,srvhp=0x144e768)

4 ETW000 54 0.034062

4 ETW000 [dev trc ,00000] Thu Jan 3 12:55:30 2008 188993354 189.027416

4 ETW000 [dboci.c ,00000] *** ERROR => OCI-call 'OCIServerAttach' failed: rc = 12535

4 ETW000 24 189.027440

4 ETW000 [dbsloci. ,00000] *** ERROR => CONNECT failed with sql error '12535'

4 ETW000 13 189.027453

4 ETW000 [dev trc ,00000] set_ocica() -> OCI or SQL return code 12535 21 189.027474

4 ETW000 [dev trc ,00000] Try to connect with default password 12 189.027486

4 ETW000 [dev trc ,00000] Connecting as SAPR3/<pwd>@PRD on connection 0 (nls_hdl 0) ... (dbsl 640 250407)

4 ETW000 16 189.027502

4 ETW000 [dev trc ,00000] Nls CharacterSet NationalCharSet C EnvHp ErrHp ErrHpBatch

4 ETW000 12 189.027514

4 ETW000 [dev trc ,00000] 0 WE8DEC 1 0x1443790 0x144ca20 0x144c3b8

4 ETW000 12 189.027526

4 ETW000 [dev trc ,00000] server_detach(con_hdl=0,stale=0,svrhp=0x144e768)

4 ETW000 11 189.027537

4 ETW000 [dev trc ,00000] Detaching from DB Server (con_hdl=0,svchp=0x144c2e8,srvhp=0x144e768)

4 ETW000 10 189.027547

4 ETW000 [dev trc ,00000] Deallocating server context handle 0x144e768 41 189.027588

4 ETW000 [dev trc ,00000] Allocating server context handle 34 189.027622

4 ETW000 [dev trc ,00000] Attaching to DB Server PRD (con_hdl=0,svchp=0x144c2e8,srvhp=0x144e768)

4 ETW000 25 189.027647

4 ETW000 [dev trc ,00000] Thu Jan 3 12:58:39 2008 188997623 378.025270

4 ETW000 [dboci.c ,00000] *** ERROR => OCI-call 'OCIServerAttach' failed: rc = 12535

4 ETW000 20 378.025290

4 ETW000 [dbsloci. ,00000] *** ERROR => CONNECT failed with sql error '12535'

4 ETW000 14 378.025304

4 ETW000 [dev trc ,00000] set_ocica() -> OCI or SQL return code 12535 9 378.025313

4 ETW000 [dblink ,00428] ***LOG BY2=>sql error 12535 performing CON [dblink#3 @ 428]

4 ETW000 123 378.025436

4 ETW000 [dblink ,00428] ***LOG BY0=>ORA-12535: TNS:operation timed out [dblink#3 @ 428]

4 ETW000 11 378.025447

2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'PRD'"

Anybody an idea what to do??

Kind regards,

Sandro Gerstenberger