Skip to Content
0

HCI Agent Configuration Issue

Oct 17, 2016 at 09:47 AM

155

avatar image

Hi All

I am facing the below error when i am trying to upload the configuration file through the Agent. The Agent gets closed but doesn’t restarts when i click on upload.

This is the Log generated..

[Oct 14, 2016 16:09:27] INFO : Loading.. from DSConfig
[Oct 14, 2016 16:09:27] INFO : AgentDirectories.dirCount : 1
[Oct 14, 2016 16:09:27] INFO : AgentDirectories.dir1 : C:/ProgramData/SAP/DataServicesAgent/workspace
[Oct 14, 2016 16:10:20] INFO : Is Agent Service running, return value:false
[Oct 14, 2016 16:10:20] INFO : Config file content :
[Oct 14, 2016 16:10:20] INFO : <?xml version=”1.0″ encoding=”UTF-8″?><configuration><agent>VIG</agent><organization>removed by me</organization><dataloader>https://hcids.hana.ondemand.com/DSoD/agentmanager/data_loader</dataloader><agentmanager>https://hcids.hana.ondemand.com/DSoD/agentmanager</agentmanager><dsod>https://hcids.hana.ondemand.com/DSoD</dsod><ssl>true</ssl><timeout>20</timeout><deployment>NEO</deployment></configuration>;
[Oct 14, 2016 16:10:20] INFO : agent : VIG
[Oct 14, 2016 16:10:20] INFO : organization : removed by me
[Oct 14, 2016 16:10:20] INFO : dataloader :https://hcids.hana.ondemand.com/DSoD/agentmanager/data_loader
[Oct 14, 2016 16:10:20] INFO : agentmanager :https://hcids.hana.ondemand.com/DSoD/agentmanager
[Oct 14, 2016 16:10:20] INFO : dsod : https://hcids.hana.ondemand.com/DSoD
[Oct 14, 2016 16:10:20] INFO : ssl : true
[Oct 14, 2016 16:10:20] INFO : timeout : 20
[Oct 14, 2016 16:10:20] INFO : deployment : NEO
[Oct 14, 2016 16:10:20] INFO : running generate_dsod_agent_keys.bat
[Oct 14, 2016 16:10:20] INFO : Agent Name = VIG
[Oct 14, 2016 16:10:20] INFO : Org Id = removed by me
[Oct 14, 2016 16:10:20] INFO : UTC timestamp = 161014102520Z
[Oct 14, 2016 16:10:20] INFO : Execute Command: “generate_dsod_agent_keys.bat VIG”
[Oct 14, 2016 16:10:21] INFO : Working directory: C:\Program Files\SAP\DataServicesAgent\bin
[Oct 14, 2016 16:10:21] INFO : Return Code: 0
[Oct 14, 2016 16:10:21] INFO : running generate_dsod_agent_keys.bat…Done
[Oct 14, 2016 16:10:23] INFO :
Using the following for upload certificates:
[Oct 14, 2016 16:10:23] INFO : dsodBaseUrl = https://hcids.hana.ondemand.com/DSoD
[Oct 14, 2016 16:10:23] INFO : certFile = C:\Program Files\SAP\DataServicesAgent\ssl\dsod_agent\dsod_agent.crt – The certificate is successfully generated but the upload process is not happening after that.
[Oct 14, 2016 16:10:23] INFO : tenantAdminUser = removed by me
[Oct 14, 2016 16:10:23] INFO : orgGuid = removed by me
[Oct 14, 2016 16:10:23] INFO : deployment = NEO

Please suggest some solution for the same.

Thanks in advance

Vignesh J

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

avatar image
Former Member Jan 05, 2017 at 07:44 PM
0

Hi, @vignesh.jeyabalan2

Im new in HCI, I need to install the Data Services Agent for HCI, I do not have very clear which user and password to use for this purpose. I need help with this.

I understand that you have been able to solve this same problem.

Thanks for everything.
Regards.


agent-ds.png (25.6 kB)
Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Juan,

When you install the agent you need to use your machine's admin username and password. If the current user does not work create one more user as admin and try with that.

For certificate upload you need to use your HCI username and password.

0

Hi @Juan Camilo Jaramillo,

If you are in a company network. then company domain\ your system user name (ex: SAP\VIGN ). Make sure you have admin rights to install a software on the machine.

Thanks

Vignesh

0