Skip to Content

WEBIDE Extend panle was empty

Oct 30, 2017 at 03:18 AM


avatar image

hi, firends

when i use WEBIDE to extend FIORI Inbox , the extend panle was emtpy. But the sometimes outline has ui elements. Can somebody knows how to sovle this issue?

Thanks very much!

the screen shortcut as blow

1.png (385.9 kB)
2.png (180.3 kB)
3.png (226.0 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Michal Keidar
Oct 31, 2017 at 02:47 PM


How is your destination configured?

Does your system have several application servers?
Usually, when using a Web Dispatcher, session stickiness is ensured, however this is not the case if the message server of the system is used for load balancing of HTTP requests. This is a known limitation that should be avoided.
If the message server of your system is configured either in your destination in the cockpit or in your cloud connector, this should be changed. Either use a real Web Dispatcher or specify the specific app server.


Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi, First, thanks for you reply.

In my case, I used localtion WEBIDE. And the configration about destination as blow. When I develop other ui5 app , it's work fine,except extend Inbox app. Our system have application server and the gateway component with in application server.



I didn't get your destination configuration...

Milen Dontcheff
Oct 30, 2017 at 01:24 PM


Please cross check the Component.js file.

It should contain something like this:

// use the load function for getting the optimized preload file if presentsap.ui.component.load({ name: "cross.fnd.fiori.inbox", // Use the below URL to run the extended application when SAP-delivered application is deployed on SAPUI5 ABAP Repository url: "/sap/bc/ui5_ui5/sap/CA_FIORI_INBOX" // we use a URL relative to our own component // extension application is deployed with customer namespace});
this.cross.fnd.fiori.inbox.Component.extend("cross.fnd.fiori.inbox.CA_FIORI_INBOX_PM_WF_Ext.Component", { metadata: { manifest: "json" }});



If 1. is ok - please try creating a new extension project for CA_FIORI_INBOX and run it. Does it open properly?

If so, try to copy your extensions to it and run it again.


By the way, what is the My Inbox version

(Go to My Inbox > User drop down at right hand corner > Open Support Information > Provide Technical version).

Please post the SAPUI5 version as well.

10 |10000 characters needed characters left characters exceeded