Skip to Content
avatar image
Former Member

Time Out Error while execution of messages

Hello All,

Our Env. is XI 3.0 , and this is related to PRD system,

This problem is relating to an Outbound service. This particular message gets executed in some times and in some cases it throws Time out Exception .

This is the following log which is from Audit log of that message :

***********************************************************************

Audit Log for Message: 2949b051-ae64-11dc-87b9-001560ad9210

Status Description

Success RFC adapter received sRFC for Z_UCRM_FM029_RFC_INT_SERASA from CP1/130. Attempting to send message synchronously

Success Application attempting to send an XI message synchronously using connection AFW.

Success Trying to put the message into the call queue.

Success Message successfully put into the queue.

Success The message was successfully retrieved from the call queue.

Success The message status set to DLNG.

Error Returning synchronous error notification to calling application: com.sap.aii.af.ra.ms.api.RecoverableException: Received HTTP response code 500 : Timeout.

Error Transmitting the message using connection http://xp0ci01:8080/sap/xi/engine?type=entry failed, due to: com.sap.aii.af.ra.ms.api.DeliveryException: Received HTTP response code 500 : Timeout.

Error The message status set to FAIL.

Error Returning to application. Exception: com.sap.aii.af.ra.ms.api.DeliveryException: Received HTTP response code 500 : Timeout

**************************************************************

Here CP1/130 is the CRM system which is sender in this case , and XP0 is xi production system.

Can any one help me out to fix this issue, and if any parameter value need to be adjusted...?

Best Regards

Rakesh Reddy

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Dec 24, 2007 at 12:48 PM

    Hi Rakesh,

    Refer SAP note 824554 for timeout error

    Regards,

    Prakash

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 24, 2007 at 12:50 PM

    Hi,

    Refer sap note 1001292.

    problem :

    During synchronization, an error "Problems during synchronization: Contact your administrator" is displayed in the sync log.

    Server returned HTTP response code: 500 during synchronization.

    Device id is not generated.

    Solution :

    For WebAS 6.40:

    Apply Support Package 20

    or

    Apply 1001292 note via Note Assistant(SNOTE)

    For WebAS 7.0:

    Apply Support Package 11

    or

    Apply 1001292 note via Note Assistant(SNOTE)

    Hope this will help you.

    Regards

    Aashish Sinha

    PS : reward points if helpful

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello All,

      Thanks for the update,

      I have checked the mentioned Blog and the oss notes mentioned in it..

      I have compared all the parameters specified in it , and which seems to be fine as per recomended.

      *****************************

      HTTP_TIMEOUT -30000

      syncMessageDeliveryTimeoutMsec --300000

      xiadapter.inbound.timeout.default -180000

      ******************************

      Few points which I am having doubt :

      1>

      When I login to SMICM of that system , I can find the error content in most areas and no clue about it..

      *****************************

      [Thr 1077967200] Wed Dec 26 17:29:19 2007

      [Thr 1077967200] *** WARNING => IcmReadFromConn: AppServer context already released [icxxthrio_mt 2452]

      [Thr 1077967200] *** ERROR => IcmHandleNetRead(id=7/22059): IcmReadFromConn failed (rc = -1) [icxxthrio_mt 1257]

      [Thr 1077967200] *** ERROR => IcmConnRollInWP: AppServer context already released [icxxthr_mt.c 2339]

      ********************************

      2>

      And when checked in trace file of dev_server0 , i can see some error messages relating to rfc logon load(SMLG) , but I have checked in SMLG and load balancing is defined over there and the status is also green.

      Now one small doubt is , any way this error is relating to the existing problem ..

      ****************************

      [Thr 1093638496] Thu Dec 27 12:09:18 2007

      [Thr 1093638496] *** ERROR => JRFC> Error jrfc_lg LgGroup failed(-6) [jrfc_mt.c 707]

      [Thr 1093638496] *** ERROR => mshost: ashb01wa06pr, msserv: sapmsXP0, r_group: PUBLIC [jrfc_mt.c 708]

      ****************************************

      3>Is my only few outbound services messages getting failed showing the reason as "Timeout error 500 " due to inconsistency in SMICM .(as outbound services uses ICM services to connect external part)..

      4>And the reason for failing only some messages is due to heavy load( at same time many messages are getting executed) ?

      Can any one help me to fix this issue ...

      Best Regards

      Rakesh Reddy