Skip to Content
avatar image
Former Member

WebIDE - Deploy to SAPUI5 ABAP Repository not working

When deploying a random WebIDE UI5 project to our internal system (using option 'Deploy to SAPUI5 ABAP Repository'), I get following error: "404 - Not found. The server has not found any resource matching /sap/bc/adt/discovery".

The service /sap/bc/adt is enabled in SICF, the local cloud connector is installed successfully on the server machine itself as well as defined the Cockpit (connectivity - destinations). We are using Netweaver 7.5 (EWM 9.4).

Do you have any ideas what can be done to get rid of the error?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Oct 30, 2017 at 10:47 PM

    1) Can you access <host>:<port>/sap/bc/adt/discovery directly from the broweser?

    2) Did you maintain the "dev_abap" and "ui5_execute_abap" usage in destinations?

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 31, 2017 at 01:30 PM

    Have you tried to connect to when you have configured a Principal Propagation Authentication:

    Configure Principal Propagation to an ABAP System for HTTPS

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 13 at 06:15 AM

    Did you find a solution for this error message? I am struggling with the same error.

    1) Can you access <host>:<port>/sap/bc/adt/discovery directly from the broweser?

    Yes i can.

    2) Did you maintain the "dev_abap" and "ui5_execute_abap" usage in destinations?

    Yes i did.

    Add comment
    10|10000 characters needed characters exceeded