Skip to Content
0

How to connect SAP HANA 2.0 express with SAP Lumira 2.0 ?

Oct 27, 2017 at 09:09 PM

701

avatar image

Hello

When I try to access SAP HANA 2.0 SP02 Live Views using Lumira 2.0 SP02 Discovery, Lumira cannot reach SAP HANA express 2.0 SP02: I get the message “Unable to connect to http://hxehost:8090”

When I was deploying the INA Service I got this message with the GetServerInfo URL

https://hxehost:4390/sap/bc/ina/service/v2/GetServerInfo :

{
“Messages”: [
{
“Number”: 42001,
“Type”: 2,
“Text”: “InformationAccess Service GetServerInfo is not available. Install the SAP HANA EPM-MDS plugin.”
}
]
}

Once I installed the SAP HANA EPM-MDS plugin, I get this message:

{
“Grids”: [],
“ItemLists”: [],
“Messages”: [{
“Number”: 200,
“Text”: “No servers are available. Error: No error”,
“Type”: 2
}]
}

Im still getting the message “Unable to connect to http://hxehost:8090” when I try to connect from Lumira 2.0 SP02. Can someone tell me what is missing?.
Thanks.

Regards

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Thomas Jung
Oct 30, 2017 at 02:02 PM
0

HANA Live View requires the INA interface which in turn require the EPM-MDS plug-in as of HANA 2.0. Unfortunately the current version of SAP HANA Express Edition does not come with the EPM-MDS plug-in. If you have a full license for HANA as well, you can download this EPM-MDS plug-in from the software download center of the Service Marketplace and install it with hdblcm.

Show 8 Share
10 |10000 characters needed characters left characters exceeded

Hello Thomas,

I have already installed the SAP HANA EPM-MDS plugin from the Service Marketplace "SAP HANA EPM-MDS 1.0 (SUPPORT PACKAGES AND PATCHES)", I used the file:

IMDB_EPMMDS_2020P_4-80002211.SAR EPMMDS Rev 20.4 only for HANA 2.0 Rev 20

I dont understand why I am getting this message when I check the GetServerInfo URL ( https://hxehost:4390/sap/bc/ina/service/v2/GetServerInfo ) :

{
“Grids”: [],
“ItemLists”: [],
“Messages”: [{
“Number”: 200,
“Text”: “No servers are available. Error: No error”,
“Type”: 2
}]
}

This can't work with SAP HANA 2.0 Express Edition?, it looks like some other services are missing.

Should I use a new installation of SAP HANA instead Express Edition?

Thank your for your help.

Regards

0

This error has to do with the MDC configuration and the XSEngine. I got this error as well recently when setting up this scenario and had to make sure that XSEngine was properly configured on my tenant DB as well.

0

Hi Thomas, how can i make sure that the XSEngine is properly configured on the tenant DB? I am working with the VM SAP HANA 2.0 Express Edition, we might have the same configuration. Did you make this scenario work?

I was searching for a guide to set up this, but I did not find anything to solve this.

Thank you very much for your help,

Regards

0

Hi, I had taken screenshots of my setup process for HANA Express on GCP so here's a blog on what I did to make it work: https://blogs.sap.com/2017/11/02/configure-information-access-in-hana-express-to-connect-from-lumira-or-analysis-for-office/

0

Thank You Lucia, I will follow those steps.

0
0

Actually I just spoke to @Lucia Subatin and she had the same issue on HXE. Her HXE is more "pure" than mine since I installed from the binaries. In her system the first tenant was disabled. It had to be re-enabled via SQL: ALTER SYSTEM START DATABASE <database_name>. In my system I'd gone a step further and initially deactived the web dispatcher for the entire XSEngine and also had to re-enable it for the tenant after restarting it. After speaking to Lucia, I don't believe that in standard HXE that extra step will be necessary, but you have the instructions in the blog link above if so.

0

Hello Thomas, I've just seen that Lucia has done the configuration, I will try those steps. Thank you for all your assistance.

0
Tammy Powlas
Oct 28, 2017 at 08:47 AM
0

Hi Aldo - have you followed all the steps in this blog? https://blogs.sap.com/2017/06/10/sap-hana-live-analysis-with-lumira-2.0-an-overview/ - is the XS port up and running? Firewall ports open?

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hello Tammy,

1) have you followed all the steps in this blog?

I'm following those steps but I can't continue because I don't get the correct response in this step "Verifying the URL for the SAP HANA HTTP connection" ( https://archive.sap.com/documents/docs/DOC-64277 ).

I'm using the link "https://hxehost:4390/sap/bc/ina/service/v2/GetServerInfo" to check the response. Also I'm trying to connect using "SAP HANA Local/Direct Connection".

2) is the XS port up and running?

Yes, I think so. When I check the URL "http://hxehost:8090" I get the message XS Engine is running.

3) Firewall ports open?

I don't know if they are open, how can I check that?. I'm using the VM SAP HANA Express 2.0 SP02, maybe the ports are open by default.

Thank you for your help.

Regards

0

#3 - you need to check with your network administrator...this is something I don't have any knowledge on.

0
Mike Howles
Oct 31, 2017 at 09:51 PM
0

Aldo, basically same problem I posted 2-3 weeks ago here:

https://answers.sap.com/questions/307529/informationaccess-ina-not-available-in-hxe-20.html

I didn't really get any good news on this one. Sadly, this was available in HXE 1.0 which cannot be downloaded anymore :(

Show 2 Share
10 |10000 characters needed characters left characters exceeded
0

Yes, I would have already downloaded the EPMMDS plugin, if we were licensed for HANA already, which we are not. This is why I am so actively interested in using Express Edition to try some small projects to get some buy-in to progress to a larger HANA.

0