Skip to Content

Script button not visible

Oct 27, 2017 at 10:11 AM


avatar image


I have this script buttons on Persona which I can see while editing but when I run the persona it's not visible.

Just to add, I only see this issue when buttons are placed in the container within the template.

I tried options 'Bring Forward' and 'Bring to Front' on script buttons and tried 'Send back' and 'Send to Back' on the template.

Buttons in question are 'Material' and 'Vendor'.

Below screenshot while editing.

Below screenshot while running. Notice 'Material' button missing. If I put 'Vendor' button in template's container then it will also disappear.

I tried to use script editor to inspect the 'Material' button but it's not there on screen (possibly behind the template).

1.jpg (44.2 kB)
1.jpg (23.9 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Tamas Hoznek
Oct 27, 2017 at 04:48 PM

Instead of first creating the button and then dragging it into the template placeholder, first select the placeholder, then insert the button directly into it.

Of course everything should work even when dragging the custom control into the placeholder, but this is an identified bug which needs to be fixed.

Also, you should use the dedicated openSAP course forum to deal with issues experienced during the class, instead of the SAP Community. This issue has been covered there at length already.

10 |10000 characters needed characters left characters exceeded