Skip to Content
0

Missing required start tag within IDoc-XML

Oct 26, 2017 at 09:54 AM

99

avatar image

Hi

We are working on migration project, we are facing issue while generating idoc-xml in pi

ERror:

IDOC_ERROR_PARSE_FAILURE: Missing required <EDI_DC40 SEGMENT="1"> start tag within IDoc-XML for type <DEBMAS06>:
state=READING_CONTROLRECORD_STARTTAG, charPosition=88, lineNumber=1, columnNumber=89

In inbound idoc-xml payload in PI , the EDI_DC40 segment is not loading in payload, and we are not passing any partner details in mapping and we made disable the partner details.

Please share your inputs

Rg

Kumar.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

6 Answers

Raghuraman S Oct 26, 2017 at 09:59 AM
0

Hello Pavan,

Check the particular field(length) in notepad+ there could be something wrong in the XML field.

Share
10 |10000 characters needed characters left characters exceeded
Pushkar Patel Oct 27, 2017 at 04:45 AM
0

Try apply control records from Payload. idoc-receiver-adapter.jpg


Thanks,
Pushkar


Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Pushkar Patel,

we try this option too, but still no luck.

regards

pavan.

0
Manoj K Oct 26, 2017 at 10:06 AM
0

Pavan,

If you are not populating control record then how is the idoc posting done ? i mean on how is the decision made in ECC syaing whihc customer has sent you this data ?

You can use "OverRide Control Record" option in Reciever IDOC_AAE channel .

Br,

Manoj

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Manoj

thanx for ur inputs,

We are not sending the partner details in EDI_DC40 segment, and more over EDI_DC40 segment not crating in payload in PI . PFA screnshotedidc.jpg

Atleast EDI_DC40 segment should be created ?

regards

pavan.

edidc.jpg (32.1 kB)
0

Can you check in mapping if you have disabled the EDI_DC40 segment? enable that and give it a try.

0
pavan kumar Oct 26, 2017 at 12:46 PM
0

Hi Manoj

Yes enabled and disabled all the mandatory fields, but still EDI_DC40 segment not created in payload,

Regards

pavan.maping.jpg


maping.jpg (63.3 kB)
Share
10 |10000 characters needed characters left characters exceeded
Rajesh Kannan K Oct 30, 2017 at 09:54 AM
0

Hi Pavan,

Are you using any standard module bean for generating IDOC-XML from your input?

Share
10 |10000 characters needed characters left characters exceeded
pavan kumar Oct 30, 2017 at 10:55 AM
0

Hi

No we are not using any standard module bean for generating IDOC-XML .

Rg

Kumar.

Share
10 |10000 characters needed characters left characters exceeded