Skip to Content

Data Mashup cannot find REST Service

Oct 25, 2017 at 09:45 PM


avatar image


I am attempting to loosely follow the directions in this blog post: (but with our company's API endpoints), and I'm having difficulty.

I am able to successfully create the mashup web service, and when I simulate it it correctly lays out the response.

When I begin to define the data mashup, I correctly see the Port Binding I created and can map to that.

When I move to Define Mashup Details, things begin to get strange. I don't see any of the labels in the left or right sections.

I move down to Sources, drag in the REST Service, and this popup appears.

No matter what I do, there are only these two REST Services (despite having ~16, including the one I just created, in the list). I cannot figure out why only two or how to get the others to appear.

Any suggestions on what I'm doing wrong?



screenshot-17.png (629.5 kB)
screenshot-18.png (188.1 kB)
screenshot-19.png (228.5 kB)
screenshot-20.png (255.0 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Vandre Philippsen
Oct 31, 2017 at 01:24 PM

Hi Jason,

The REST Service need be based on XML and in the mashup change "Service Protocol" to XML. Currently with Silverlight UI mashup authoring we only support the XML format. In future releases for HTML5 UI we planned to support JSON format, but without exact forecast.

You can also submit your feature request our Ideas Place on that is the official tool to propose new functions and share scenarios like this.

Best Regards,

Vandre Philippsen

10 |10000 characters needed characters left characters exceeded