Skip to Content
0

suppress odbc messages

Oct 17, 2016 at 01:15 AM

53

avatar image

I am getting the error message:


[HYT00][SAP][ASE ODBC Driver]The command has timed out

and it waits for me to click continue or quit.
I do not want this displayed. I just want it to continue. My app loops and if it is able to connect then it writes to a table . If not then it waits to connect again.

I have a .net cs file and no where in there do I display this error message. Where and what do I code to suppress this error message?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Maria-Cristina NORMAND
Oct 24, 2016 at 08:14 PM
0

Hello,

You could consider to modify the connection properties to specific no limit to the wait time ?

Regards,

Cris

Share
10 |10000 characters needed characters left characters exceeded
Ryan Hansen
Nov 01, 2016 at 05:11 PM
0

Hi,

ODBC doesn't disconnect on its own (or shouldn't).

Check your application for any timeouts set for the command/query.

Connectionstring setting is CommandTimeOut, if this is set then it will timeout, if it is not set it has no timelimit.

http://infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.dc20116.1570/html/aseodbc/CHDCGBEH.htm

You could also try IgnoreErrorsIfRS Pending = 1

Regards,

Ryan

Share
10 |10000 characters needed characters left characters exceeded