Skip to Content

Trying to connect Analysis for Office to SAP HANA 2 Express

Oct 23, 2017 at 06:45 PM


avatar image

Hi, I'm trying to connect SAP Analysis for Office 2.5 to my local Virtual SAP HANA Express 2.0 SP00. I've done all the steps, well explained, in the following article:

Testing the connection by AAO 2.5 I've obtained the following error:

Testing a little deeper using the following link:


I've obtained this error:

{"Messages":[{"Number":42001,"Type":2,"Text":"INA library not available. Install EPM."}]}

Getting into detail, I've found that the hierarchy packages of INA SERVICE were present in the current HANA Installation but the message error still got present. Looking inside the delivery units via HANA STUDIO I haven't find the package HCO_INA_SERVICE inside the HANA installation folders on the virtual machine. Instead I've found AHCO_INA_SERVICE. It's the same?

Looking around about notes, messages, incidents and KBAs, I 've found only few articles driving me to permissions, which I've checked and are all enabled, or install BPC components. Here below some notes with some authorization and privileges to set up:

2097965 - Additional setting for using the HANA Service Information Access
2141541 - Additional customizing steps for the HANA Information Access (InA) Service 2242449 - Additional information for SAP HANA Information Access (InA) Service defect resolution
2315536 - HANA InA role 1773751Design Studio - Support Note for Client
2193057 Configuring the new HTTP based data source access to SAP HANA in Design Studio 1.5
2133992 SBOP Design Studio 1.5: Release Note for First Delivery
2154859 Design Studio - Support Note for SAP HANA

One of these notes (2316919 - MDS user configuration) give some deeper details about privileges and authorization but the issue is still present. Moreover, it gave me the clue of upgrading the HANA installation, which I did. Downloaded the last update last week (HANA DB Version: I've tried to configure again the connection but the issue is still present.


with the following checking link
I've obtained a similar error which I've gained before: "InformationAccess Service GetServerInfo is not available. Install the SAP HANA EPM-MDS plugin."

During the AAO configuration, this pop-up came out asking me for an user and password which I didn't understand well.


I presume should be filled with user which have the following grant: sap.bc.ina.service.v2.userRole::INA_USER + the grants described in the note: 2316919 - MDS user configuration.

Moreover, I've checked in the new installation and found out that no HCO_INA_SERVICE package is present in the DU delivered with the Virtual Machine.

Could anyone please help me to find a solution?



aao-error2.png (110.8 kB)
aao-error3.png (88.1 kB)
aao-error.png (41.4 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Richard D'Abbadie Nov 08, 2017 at 07:49 AM

HI Marco,

Have a look at the following blog. I am busy with the same issue.

Richard d'Abbadie

10 |10000 characters needed characters left characters exceeded
Marco Tavernini Nov 12, 2017 at 08:30 AM

Hi Richard,

Sorry for my late answer; during these days I've followed the instructions of the article and for the first part of the article everything went fine. I've run in the browser the following command: "http://hxe.hxehost:80XX/sap/bc/ina/service/v2/GetServerInfo" and I've obtained the same result as in the image. Perfect!!!

Now, following and complete the second part of the article (Configure the tenant database), I still find some error related to permissions and grants.

After appliyng the command and settings and to ran both the commands:



The browser asked me an user and password to login and never get the result shown in the article.

I've tried insert credentials of the following users: Training (a dedicated users), XSA_ADMIN, and SYSTEM user

and for the SYSTEM user, HANA returned (403) forbidden while for Training and XSA_ADMIN, HANA returned (401) Unauthorized.

When I've tried to access using Analysis for Office and result was the same.

I believe to be a step more than before but enough.

Just to give more information, I've added more grants to the users XSA_ADMIN and Training like suggested in the following article and notes:

2207175 - 403 forbidden issue occur while logging on AO client 2.0 with local SAP HANA connection

How to Resolve Remote server returned an error:(403) Forbidden while connecting to HANA HTTP using Analysis Office 2.x

InformationAccess (INA) not available in HXE 2.0

But the last issue still remain.

Now my question is, which kind of grants and authorizations still need to complete the task.

Thank you,


aao-error4.png (39.8 kB)
aao-error5.png (65.1 kB)
10 |10000 characters needed characters left characters exceeded
Marco Tavernini Nov 19, 2017 at 11:10 AM

Hi Richiard, I want to update you and the folks that I've reinstalled again, as brand new installation, HANA 2.0 SP2 on VM and install the package SAP_HANA_EPM-MDS as add-on. Following strictly what Lucia Subatin wrote in her blog, I finally could use SAP Analysis for Office (in my case version 2.5) with my SAP HANa Demo environment :-). So for me now is everything fine.



10 |10000 characters needed characters left characters exceeded