Skip to Content
avatar image
Former Member

System Landscape Directory server not started

Hi,

We are running Solution Manager 4.0 SP13.

When I log ito the NWA get the message : System Landscape Directory server not started

We are trying to configure CEN but only the Local System can be administered.

If I goto the Central SLD and login - Administration - Server Started.

If I look at the ABAP - Transaction SLDAPICUST - save configuration - all ok

I goto the Jco Connectors and ensure all Jco Connections are configured: SAPSLDAPI_SID

ABAP RFCs; All configured

ABAP - Transaction - sldcheck .. it returns with success.

I login to the ABAP stack - smgw - logged in clients and all Jco Connections are available

I go into the J2ee Admin - navigate to the SLD Data supplier - all tests return success.

The SLD CIM is version 1.5.20

The application com.sap.engine.class.download is started ( Note 1017526 )

However when I login to with the J2ee_admin tool the following is missing from the CIM Client:

sap.com/tclmwebadminmainframewd/webdynpro/public/lib/app.jar

sap.com/tclmwebadminsldwd/webdynpro/public/lib/app.jar

Please help.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Dec 19, 2007 at 02:05 PM

    Hello Clive,

    You need to perform some Post-installation steps after installation of SLD component, and this includes steps like importing CIM files, creating roles and assigning them to the respective users. Go through Post installation guide for SLD where u may get a clear picture. Also check for object server and data supplier.

    Post-Installation Guide - SLD of SAP NetWeaver 7.0

    regards,

    Anand

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Anand,

      I verified the SLD Post Processing doc in case I missed something. The doc I used:

      https://websmp106.sap-ag.de/~sapidb/011000358700003772372006E

      I went through every point in the doc and verified that it was completed .

      If I open Monitoring Setup Guide for SAP NetWeaver 7.0 SP Stack 12 ( Can't find 13 ) I go to page 68 :

      6.5.2. Configuring the Connection Between CEN and the SLD ... I have followed all the steps without any error.:

      I followed it Step-by-Step.... however the following CIM Client Genearations do not exist:

      sap.com/tclmwebadminmainframewd/webdynpro/public/lib/app.jar

      sap.com/tclmwebadminsldwd/webdynpro/public/lib/app.jar

      What is available and Activated :

      sap.com/tclmwebadminmainframewd/webdynpro/public/lib/sap.comtclmwebadminmainframe~wd.jar

      sap.com/tclmwebadminsldwd/webdynpro/public/lib/sap.comtclmwebadminsld~wd.jar

      I alos Decided for the purpose of Troubleshooting to Activate All:

      sap.com/tclmwebadmin~mainframe.......

      sap.com/tclmwebadmin~sld..........

      When I go into NWA .. its still says SLD Not started.

      If I go inot the J2ee Admin Tool - SLD Data Supplier - Trigger Data Transfer OK

      I goto the SLD - Administration . SLD Started

      I Can see all the Techinical systems - ABAP and Java.

      All business Systems are there

      SLDCHECK works fine .. no errors !

      But I can't change the status of the NWA System Landscape Selectipon From Local to Central.

      Warning / Error :

      System Landscape Directory server not started

      and

      Only local system can be administered

      I maybe missing something but I can't see what it is....

      Further Help required !

  • avatar image
    Former Member
    Feb 19, 2008 at 08:34 PM

    Run report AI_SC_MIGRATION in SolMan to fix the problem

    Add comment
    10|10000 characters needed characters exceeded