Skip to Content
avatar image
Former Member

IDX2 doens't refresh IDoc structure

Hello everybody,

I have a problem with the IDX2. There is a Z IDoc which has changed. So I deleted the old entry in the IDX2 and load it again from the system. But the structure is not refreshed. I tryed to load it from another XI System (the development XI and not the quality XI) but from the same R/3 backend. And there the structure is refreshed. So it seems to be a problem of the XI and not the R/3 backend.

We are on NW04s SPS 13.

Did anybody know this problem and can help me.

Thanks

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Dec 18, 2007 at 01:36 PM

    Hi,

    In SAP XI 3.0 SP >= 17 there is a report: IDX_CHECK_METADATA which compares/deletes matadata.

    In SAP XI 3.0 SP < 17 there is a report IDX_RESET_METADATA which deletes matadata.

    Regards,

    Jakub

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 18, 2007 at 12:43 PM

    Hi,

    Following two should solve your problem:

    Goto IDX1 edit port and then save it again it will refresh connection b/w R/3 and XI.

    Goto IDX2 delete metadata and import Idoc again.

    You can also refer to note: 907957 (not sure as you are already on higher patch)

    Regards,

    Gourav

    ---

    Reward points if it helps you

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 18, 2007 at 12:49 PM

    Hi,

    Check whether the port is correctly configured in IDX1. Make sure it is working.

    Regards,

    Divija.

    Edited by: Divija KN on Dec 18, 2007 1:49 PM

    Add comment
    10|10000 characters needed characters exceeded