Skip to Content

Web workbench: Importing package from archive gives 404 when running xsjs/html etc

Oct 23, 2017 at 12:28 PM


avatar image


I have been to a workshop at SAP HQ in London. We learned some xsjs and ended up with a project that we could import into our own SAP HANA environment.

However when importing a package from archive, then nothing seems to work.

I click the root node in the workbench code editor: Content->New->Package. Then i right click the package: Import->Archive. I select the archive and when i run an xsjs file then i get this 404 screen:

The weird thing is that if I again create a new package and afterwards creates a new file in this package and copies the content of the xsjs file, then everything works fine.

So to summarize:

- It does not work when importing a previous exported project - i end up with a 404 no matter what file i run.

- It works when i create a new package, create a new file and copies the content of the xsjs file.

I am completely new to SAP. So what could i be doing wrong during the import of the package since i always get a 404 when running the files?

Best regards,


404error.png (76.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers