Skip to Content
avatar image
Former Member

Buiness Objects Distributed Installation

Hi,

we are in process of installing Business Objects as distributed and having issues. Not sure what I did wrong as this is first time I am working on it. Read few articles but not sure if they are applicable to my issue.

Installed 3 systems with Web, Intelligence and Management. DB is on a different server. Management server say server A has been installed with selected services, Server B which is Intelligence server was asking for existing CMS server. I assume CMS server is Server A or it is the DB name ? Can you please advise ? EVen for Web Tier it is asking for existing CMS server name.

Do I have to follow any Post steps after installing Web tier as I am not getting CMC logon page. I am missing something but not sure what it is. I really appreciate if anybody can guide me through this issue. Thanks

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Oct 24, 2017 at 02:18 PM

    you need to provide details of server A while installing intelligence or webi tier.DB server is connected with server A and server A will be with others.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks Amit. Environments variables are already in place but still gets the error. Do we need any other Environmetns variable other than PATH ?

  • Oct 24, 2017 at 02:59 PM

    Hi,

    The error message that you mentioned:

    Reason: Database access error. Reason loading shared object failed. First tried to load library oci and failed because of error. The specified module could not be found. Second tried to load library { Business Objects Path }\win64_x64\oci.dll and failed because of error. the specified module could not be found.


    Occurs when it is not able to find the path specified. You need to specify Oracle's BIN directory path in the PATH variable. See the 'Resolution' section in SAP KBA:

    1845989 - Failed to retrieve cluster name from database

    You will need a restart of the server box.

    Secondly, make sure there is no Firewall in between the distributed environment nodes. If there is a Firewall, make sure the required ports are opened. See SAP KBA:

    2276646 - Firewall considerations for BusinessObjects Business Intelligence Platform 4.x (Servers and Clients) [Master KBA]

    Check for any event viewer messages (errors/warnings)

    If required, make host file entry bi-directionally for the CMS node and the non-CMS nodes

    Let me know how it goes.

    Thanks,

    Megh

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      HI Megh, yes i do get error when i go to configuration tab. it is about oci.dll not found but i can see the port 6410 for SI. I have checked the environments variables and everything is working as expected.

      SIA is not stopped. it is up and running.

      hope this answers to your questions ?