Skip to Content
0

Change the data period in DM

Oct 24, 2017 at 11:37 AM

50

avatar image
Former Member

Hello,

In order to change the data period in DM, I would like to know the best practices since I'm a begginer in DM :)

Do I need to create a new period in DM, maintain the same Datacache and then change the period in the SAP FC reports bundle and finally execute the task to DM?

Or there is another process?

Thanks in advance

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

6 Answers

Best Answer
Marc Kuipers
Oct 25, 2017 at 11:47 PM
0

Hi Mehdi

Ok, I think I know why....took me some time to find this :)

Please refer to:

https://help.sap.com/doc/ee4d60e174631014a7da368fb0e91070/10.1.5/en-US/fc_101_win_user_en.pdf

Within this document, section

Defining the mapping between Financial Consolidation and Disclosure Management data

● Specific keywords between brackets, which you access by right-clicking in the formula row to display a contextual menu:

○ UPDPER: the data entry period located in the document axis of the reports included in the report bundle

The key here seems to be "in the document axis"

In your example, the DP is not set in the report. This will, of course, then be prompted for the user to be input (and you can set it as variable in bundle), but it seems that for the DM mapping it is not valid (I have to admit, I am not sure why not)

Could you try putting DP in the axis and see if that works?

Marc

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Oct 24, 2017 at 04:17 PM
0

Hi Marc,

Thanks for your reply,

However, when I try to follow the steps I cannot find a value in the UPDPER column :

I must of missed a step, can you please give me more details ?

Thanks,


sans-titre.jpg (228.6 kB)
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Oct 25, 2017 at 10:33 AM
0

Hi Marc,

I followed the steps, but unfortunately I get the same result :(.

This is how the report is set up in FC :

When I try to define the period mapping in the task I find "No value" in the UPDPER column.

Thanks in advance,


sans-titre.png (40.7 kB)
dfj.png (20.3 kB)
Show 2 Share
10 |10000 characters needed characters left characters exceeded

Did you set the DP in the report bundle?

0
Former Member

Yes I did set the DP in the bundle.

jh.png (21.1 kB)
0
Marc Kuipers
Oct 24, 2017 at 01:14 PM
0

Hello Mehdi,

Most customers use the "roll forward" (in the "manage periods") for this. This copies the complete period to a new one (e.g. you roll forward 2017.Q3 to 2017.Q4) and all the reports in the period are also copied. You can then even update all the data-links, so that in the reports in Q4 you reference the correct data-cache.

For FC, you can make the mapping more dynamic. See below example.

If you map period as [UPDPER] you can then define a mapping (click on the 'blue arrow' to get to this option)

You can then map FC periods (e.g. 2017.10, 2017.11) to your DM periods. In this way, if the bundle is then run for the specific FC period, it will automatically map to the correct DM period. This way, you don't need to change everything each month.

More information on: https://wiki.scn.sap.com/wiki/display/CPM/How+to+Configure+a+link+from+SAP+Financial+Consolidation+to+SAP+Disclosure+Management

Marc


Share
10 |10000 characters needed characters left characters exceeded
Marc Kuipers
Oct 24, 2017 at 09:27 PM
0

Hello Mehdi,

This comes from the FC side - it depends on how you setup your report and bundle

For example, I define my report as this (so DP needs to be set)

Then, in my bundle I set the variable

In your task, you should see these values in your mapping

Hope this helps!

Marc


Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Oct 26, 2017 at 01:51 PM
0

Hi Marc,

Thank you very much, it finally worked, I had to set the DP in the axis.

Regards,

Share
10 |10000 characters needed characters left characters exceeded