Skip to Content

CTS+ errors

Oct 23, 2017 at 03:31 PM


avatar image


We're trying to set up some non ABAP systems in SolMan (SMD) for CTS+. We have the Communication System (ABAP) as our TDMS system TDD; this is on-premise as are our non ABAP systems, so share a transport directory - we can't use SMD as it's in the cloud and doesn't share the filesystem.

We've set everything up in STMS for our non ABAP systems SDD and SDP; in TDD we have the CTSDEPLOY_SDD RFC and LPCONFIG port defined, SDD has a destination back to SMD etc etc - the "Check->transport tool" shows everything to be working.

However, when we try and test a transport in SDD we have an issue. From the SLD we are trying to export a Business System, and we get an error: Cannot get default request (for application type: SLD, user: MYUSER, SID: SDD, SC: null): Check stack trace for details [CANNOT_GET_DEFAULT_REQUEST] (

MYUSER has SAP_XI_ADMINISTRATOR_J2EE and Administrator in SDD; in SMD it has SAP_CTS_PLUS and Z_CTS_PLUS_ADDITIONAL. So I'm not sure what the problem is.

If I click "Create/Select Request" to manually create a transport, I get a different error:

Error in communication target of system SDD RFC connection of type Trusted not found for system TDD~ABAP/001; check in LMDB

We have set up SDD as a trusted system in TDD, and vice versa. This hasn't made a difference.

Anyone any ideas on either error?



10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Ross Armstrong Oct 26, 2017 at 10:02 AM

Solved it - TDD needed to be added into SMD (SolMan) as a Managed System. Then it all worked!

10 |10000 characters needed characters left characters exceeded