Skip to Content

VMware settings for installing ABAP 7.5

Oct 23, 2017 at 08:49 AM


avatar image

vm-settings.jpgyast2-settings.jpgI keep constantly getting the same error message everytime I try to install ABAP 7.5 on opensuse as per the instructions in the link below.

I have configure the vm harddrive to 150G to allow for enough space and the network adapter for the vm defaulted to 'NAT'. On the linux operating system, I have downloaded and installed the uuidd, ensuring the service up and running, entered the hosts and hostname in each file using the relevant commands, but i still keep getting the error message below when executing ./

The hostname you have chosen is either configured on a loopback device or not active on this server, please check your configuration and hostname selection. If you are confident about your choice of hostname, start the install script with -s flag to skip the hostname check

please see attached files of both my VM and YAST2 setting.

Can anyone help?

vm-settings.jpg (47.8 kB)
yast2-settings.jpg (56.3 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Mike Pokraka Oct 23, 2017 at 09:01 AM

Your attachments are missing.

Nevertheless, the error might be due to your hostname pointing to

When I used SAP on Linux (cloud is so much easier :-) ), I set up a static address or configured it on my dns server. For VMware I set it up as a shared network rather than NAT.

Show 14 Share
10 |10000 characters needed characters left characters exceeded

Hi Mike,

Thanks for replying, the attachments have now been uploaded.

How do I configure the VM to work on a shared network?


Sorry, forgot VMware calls it bridged. It means it's sharing the physical machine's network card and getting it's address details from the same DNS server as your machine. Using NAT, VMware just supplies an IP address and nobody is responsible for names and it won't be accessible from the outside.


Many Thanks Mike.

I will give it a go and let you know if the ./ executes without the error.


Hi Mike,

I've changed the settings on the VM. See attachment. Do they look correct?

I have also tried to execute the ./ and still get the same error. Do I need to change anything in my network settings (YAST2)?vm-network-adapter.jpg


Yes, VMware is OK like that.

Wasn't sure it would need it, but a domain could be what's missing.

From a command line, do:

hostname --fqdn

and see if it gives you anything after the vhcalnplci

If there is something, type this in under 'Domain' in YaST.

Else put anything in there, e.g. 'local' In this case your full hostname will be vhcalnplci.local - it might be that the install is verifying that you have a fqdn.


Hi Mike,

I've enter the command and nothing after the hostname. In the instructions it asks me enter vhcalnplci vhcalnplci.dummy.nodomain which I did. Is the later part in italic the domain name as it doesn't show up in YAST and do I need to enter that rather than local?

If I was to write in local, is the screenshot correct? It also shows an error message stating 'it's not recommended to use .local as domain name due to multicast DNS. Am I ok to proceed with this?

Many Thanks Matt


dummy.nodomain in YaST should be correct in your case.

However, either set up an explicit host and IP, or configure a hostname via YaST. But not both.

Using bridged networking you will get an IP address assigned by your external DNS, and telling the system that it's is most likely incorrect. The other alternative is to set up an explicit IP via YaST or ifconfig and configure it all manually.

The address itself must also match your local subnet. Check whether your local machine's IP address starts with 10.0.


Hi Mike,

Sorry for my lack of understanding here. It the first time I have installed ABAP on Linx, usually install it on windows. I currently have ABAP 7.3 installed on another VM.

If I write local into the VM, will the error message that I stated in my previous reply break anything?

Also, what do you mean by setting up an explicit host and IP address. Could you guide me through this? My laptop is running windows 10, VM is on Linux operating system


The principle is not specific to Linux. You're doing the Linux equivalent of setting one config up via the control panel (YaST) and then partially editing the registry (hosts, resolv.conf etc.) to possibly do something different.

I had a quick look at the blog and it doesn't mention YaST for setting up the networking, so I think by doing so and following the host file editing instructions you've ended up in the situation above.

Also, the blog provides an IP address. As I mentioned, make sure that this matches your setup. Private IP ranges are in of the ranges given here:, so under VMware bridging you have a 1 in 3 chance of getting it right by following the blog. Please use an IP address that matches your VMware host network.

So if your VMware host has an IP address of, then choose something like to be in the same routing block. Then enter dummy.nodomain as your domain in the section you first sent the screenshot of. This should work.

You should be able to do this setup entirely from YaST. If you go this route, also find the network settings where you can specify whether the IP address is dynamic or static. Write the address there.


Hi Mike,

I am right in obtaining the IP address for the local machine by viewing the properties of VMNet8 network adapter?

When I execute sudo ifconfig nothing shows up in the VM. Is this because it's using bridge?

Show more comments