Skip to Content
author's profile photo Former Member
Former Member

Problem with PI File - File Interface

Hi Gurus,

I am facing a problem when, I did a sample file to file scenario using PI ,the messages are picked by sender communication channel but they are stored in inbound queue, here the messages are locked by inbound queues. In SXMB_MONI the flags are in schedule state and queue states are showing stop. I registared and actived corresponding queus using SXMB_ADMIN Transaction, Again In smq2 queue status is showing as SYSFAIL. Under Component Monitoring in Adapter Engine adapters are not enabled.

Thanks In Advacne,

Suma B

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 13, 2007 at 07:09 AM

    Delete all the message from the queue and try to send the new message.

    Thanks

    Farooq.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 13, 2007 at 07:10 AM

    In RWB check for any CC which is in system error state, try to stop that CC & clear/delete all queues and then run your scenarion once again.

    <b>< Adapter Engine adapters are not enabled></b>

    Since now adapter monitoring is a part of CC monitoring so it will show in gry color in adapter monitoring under Component monitoring. So don't worry about it.

    Regards,

    Sarvesh

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 13, 2007 at 07:11 AM

    Hi Suma,

    Try to delete the inbound queues in TC "SMQ2"(right click and select delete LUW)............and try to process the queues which are behind them ......

    And also try to resend the messages from Adapter engine (Message monitering).........if messages are strucked............

    Reward with ponits if helpful

    Regards

    Sai ganesh

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 13, 2007 at 07:21 AM

    Hi,

    Check ur cache using T.code SXI_CACHE

    Check the Integration Process Status there.

    If every thing fine , check the Queues T. Codes : SMQR , SMQ1,SMQ2

    Then Register Quese if not.

    Pls allot point if u satisfy with this.

    With Regards,

    Mahesh Reddy

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 11, 2008 at 07:15 AM

    Thanks for your support

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.