Skip to Content
avatar image
Former Member

ODBC/JDBC prepare and like problem

Hello, i am using odbc unicode driver to maxdb and i am having the same problem described here:

http://www.mysqltalk.org/maxdb-jdbc-with-like-clause--vt76104.html

but this post it is from Jul, 2004, do we have any better way to workaround this now or this should be fixed? i have to use the method described in the post to get this work, i have tested in windows and linux with the same result. Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Dec 12, 2007 at 02:37 PM

    Hi,

    did you try to switch installation parameter USEVARIABLEINPUT to YES?

    Which version are you using? As far as I know, this bug was fixed with 7.6.03.03 no matter of the setting of this installation parameter.

    Elke

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      i have this parameter to NO, do i only can set this parameter to YES in installation? i cant do now:

      param_put -running -permanent USEVARIABLEINPUT YES

      ERR

      -24968,ERR_XPREADONLY: parameter is read only

      anyway i am using 7.6.03.07.

  • avatar image
    Former Member
    Dec 12, 2007 at 03:29 PM

    Hallo,

    the parameter-setting can be changed in offline-mode only. It cannot be changed if the database kernel is running.

    Elke

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 18, 2007 at 06:40 PM

    nobody from sap knows how to fix this? it is a bug?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Soraya,

      I have discussed the problem with colleagues and made a new test. I am sure that the ColumSize should not be necessary.

      In my C++ example it works with the sequence SQLPrepare, SQLBindParameter, SQLExecute. In the ODBC test suite there was the

      't%' stripped to 't'. I don't know why but therefore the workaround was necessary..

      For further analyses please post or mail me the ODBC Trace of your application. You can enable it in the DataSource setup. Alternatively a VTRACE will

      be helpful too.

      Best regards,

      Burkhard