Skip to Content

IDocIllegalTypeException in SAP ECC

Oct 19, 2017 at 09:48 AM


avatar image

Hi, I'm facing the problem in SAP ECC system for the following error message while receiving the IDOC from Dell Boomi to SAP ECC.

This is the Inbound IDOC to SAP ECC from Dell Boomi.

IDOC_ERROR_PARSE_FAILURE: An IDocIllegalTypeException occurred while parsing IDoc-XML for type <CUSTOM_IDOC_NAME>: state=READING_SEGMENT_STARTTAG, charPosition=436, lineNumber=15, columnNumber=15; Caused by: (4) IDOC_ERROR_ILLEGAL_TYPE: Segment type "ZDEBMAS07" is not a valid child segment type. DOCUMENT: type=CUSTOM_IDOC_TYPE; SEGMENT: type=ROOT, definition=ROOT

The given error segment is at the root level along with 2 other segments at root level, each of which are having the SAP standard child segments. To resolve this issue, I have done the following:

1. Deleted the IDOC and recreated the same.

2. Created a new IDOCs with new segment of the failed segment

3. Reconfigured all the IDOC configuration from scratch with new transport numbers

4. Created and deleted metadata in SAP ECC (although this is for SAP XI\PI)

5. Checked the notes 2023782 and 2036878, but this is for different SAP XI\PI stack, and not for ECC stack

6. Finally rebotted/restarted the SAP servers.

Even after doing all the resources available in SAP forums, the error is still not resolved. The payload structure is checked and is fine. On other hand, we tried removing this error segment and sending data for other 2 segments, which is working fine, and IDOC is received successfully.

We have done similar developments using standard IDOCs stacked into custom IDOC, which is working fine without any errors. Please let me know if anything I would have missed or any other solution. This is the SAP ECC system and NOT SAP XI\PI system. Dell Boomi resource is also checking at his end.


Hardik Mehta

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Iftah Peretz
Jan 13 at 12:39 PM


Have you looked here ? What is in the payload? Are the dates in the format "YYYMMDD"? All other format required fields are also in the correct format?

10 |10000 characters needed characters left characters exceeded