Skip to Content
0

BO 4.1 SP6 StackTrace displayed on BI Launchpad home page

Oct 17, 2017 at 03:11 PM

182

avatar image
Former Member

Hello SAP Community.

I haven't had to ask many questions this year but we eventually had to upgrade our BOxi 3.1 platform ot 4.1 SP6. I must say the 4.1 installer for windows was a dream compared to the xi3.1. I had no issues with the initial installation everything works. But I need to add a second tomcat to the same host. When I moved the wars over to the new tomcat instance via Wdeploy and restarted I get an error when i load the http://localhost:8081/BOE/BI page. The home tab (BI launch pad start page) has errors but I can see the documents in the documents tab. CMC also works fine on the 2nd tomcat instance. It is only the home page workspace on the 2nd tomcat instance that is seeing htis issue. Thank you for your support.

This is a brand new instance of BO 4.1 on a new host

Here are the details

java 1.8.0_92

tomcat 7.0.55

BOxi 4.1 SP6

This is the error displayed on the webpage.

Message org.apache.jasper.JasperException: Unable to compile class for JSP: An error occurred at line: 1 in the generated java file The type java.io.ObjectInputStream cannot be resolved. It is indirectly referenced from required .class files An error occurred at line: 302 in the jsp file: /jsp/dmdashboard.jsp The type java.util.Map$Entry cannot be resolved. It is indirectly referenced from required .class files 299: if(jsonString==null || jsonString.equals("")) 300: jsonStyle= new JSONObject(); 301: else 302: jsonStyle=new JSONObject(jsonString); 303: if(jsonStyle.has(currStyle)) 304: return jsonStyle.getString(currStyle); 305: } An error occurred at line: 68 in the jsp file: /jsp/dmdashboard.jsp The type java.lang.CharSequence cannot be resolved. It is indirectly referenced from required .class files 65: // ADAPT01446292 - 66: // The SI_CUID is taken from depot3/dashboardbuilder/trunk/PI/export/iface/deployment_files/neutral/BusinessObjects_ClientAction_AFDashboardPage_View_dfo.xml 67: String query = "SELECT SI_ID,SI_NAME, SI_APPLIED_PROPERTIES,SI_KIND,SI_ACTION_PLUGINS FROM CI_APPOBJECTS WHERE SI_KIND IN ('ClientAction') and SI_APPLIED_PROPERTIES.SI_ACTION_TYPE='View' AND SI_CUID='AbHYKw34m4pGoiLfGPfPuBM'"; 68: IInfoObjects objs=oInfoStore.query(query); 69: if (objs.size() == 1) 70: { 71: IClientAction clientAction = (IClientAction)objs.get(0); Stacktrace:

Description The server encountered an unexpected condition that prevented it from fulfilling the request.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
avatar image
Former Member Oct 17, 2017 at 07:54 PM
0

SOLVED:

I compared the tomcat1/webapps/BOE folder to the tomcat2/webapps/BOE folder and found there was about 70 files missing from the 2nd instance. No idea why because I used Wdeploy. Anyhow, I manually trued them up and restarted tomcats. Now the home page displays the default workspace dashboard.

Share
10 |10000 characters needed characters left characters exceeded
Dell Stinnett-Christy Oct 17, 2017 at 03:34 PM
0

Did you just copy the files or did you use wdeploy to deploy the site to the new Tomcat instance? In wdeploy you can specify which application server instance to use when deploying.

-Dell

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Oct 17, 2017 at 04:56 PM
0

Hello Dell,

I initially did use the wdeploy method and i reached the same outcome with the home page tab. After some research i found an article that talks about tomcat 7 and java 8 not playing nice and recommended to use an upgraded tomcat. I went to tomcat 8.5 as a test. I then went back to wdeploy to try to deploy the BOB war BUT.. the wdeploy did have an option for tomcat 8, the highest version that shows in wdeploy is tomcat 7. I can very easily go back to tomcat 7 if you feel it is not an issue. Then i will be able to use wdeploy but again I still had this issue.

There is a support document that I do not have access to that seems to talk about this exact issue. Could you possibly have access to this and can post it? https://websmp230.sap-ag.de/sap/support/notes/1931237

FYI I am logging in using the default admin account.

Thank you again, Steven

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Oct 17, 2017 at 04:57 PM
0

Here is the error.


Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Nov 07, 2017 at 06:06 AM
0

Hello, were you able to fix this issue?

Share
10 |10000 characters needed characters left characters exceeded