Skip to Content

Software Provisioning Manager SP21, Unsupported Distro

With the Fiori (?) / Browser based SWPM Sp21 I'm not able to install my playground systems on CentOS anymore.

Directly after starting the manager I'm getting the following warning:

With the old Java based SWPM I was always able to ignore such warnings. But here there's just a cancel button, which (obviously) cancels the installation.

Is there a workaround (modifying some XMLs or something) so the installation would accept CentOS? Or is it possible to connect the Java Gui (./sapinstgui) to the new SWPM?

Any ideas?

Cheers, Uwe (aka @se38)

swpm.png (9.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Oct 20, 2017 at 02:08 PM

    Hi,

    to enable the old-style GUI mode, please start the sapinst with parameter SAPINST_SLP_MODE=false:

    ./sapinst SAPINST_SLP_MODE=false

    Regarding the issue with CentOS you could give it a try with adding additional parameter SAPINST_SKIP_ERRORSTEP, but this might bring some unexpected results so please be careful :)

    Add comment
    10|10000 characters needed characters exceeded

    • Hi

      This does not work starting SP23 as the JAVA GUI is completely disabled. Is there any other way?

      The SAPINST_SKIP_ERRORSTEP=true also doesn't help as it still lands on the unsupported distribution page.

  • avatar image
    Former Member
    May 08 at 05:16 AM

    Hello,

    I have the same problem. changed temporarly the

    /etc/os-release File and added a /etc/SuSE-release.

    SWPM works!

    p00:/etc # cat SuSE-release
    SUSE Linux Enterprise Server 12 (x86_64)
    VERSION = 12
    PATCHLEVEL = 1
    # This file is deprecated and will be removed in a future service pack or release.
    # Please check /etc/os-release for details about this release.
    p00:/etc # cat /etc/os-release
    NAME="SLES"
    VERSION="12-SP1"
    VERSION_ID="12.1"
    PRETTY_NAME="SUSE Linux Enterprise Server 12 SP1"
    ID="sles"
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/o:suse:sles:12:sp1"
    p00:/etc #

    Add comment
    10|10000 characters needed characters exceeded

  • yesterday

    Hi,

    The same behavior for SWPM SP24. On ScienteficLinux(I guess the same for CentOS) change of /etc/os-release is not required. It is enough to add /etc/SuSE-release.

    Cheers,

    I.

    Add comment
    10|10000 characters needed characters exceeded