Skip to Content
0

SMP - Agentry Client Time Zone Error

Oct 19, 2017 at 11:15 AM

113

avatar image

In SMP (3.0.8) log we see error:

Client Time Zone '(UTC+00:00) Dublin, Edinburgh, Lisbon, London' alias was not found in TimeZoneAliases in Agentry.ini

I tried adding this Alias, but after entering this alias in the Time Zone Alias textarea in the SMP Cockpit. Checking the Agentry.ini file can see that the the Alias is altered to (UTC+00%3A00) Dublin, Edinburgh, Lisbon, London

So the colon (:) is automatically url escaped, and the timezone alias is not mapped. (i tried escaping the colon by using '\:', same result)

Is there a workaround?

Why is it that the Agentry Client (70.9.5.17)(Windows 10) does not send a short timezone alias to the server (like GMT Standard Time)?

Any ideas?

Joris

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Joris Mermans Nov 06, 2017 at 03:21 PM
0

I did try to change the settings of the device and putting it on some exotic time zones.

Then i put it back on GMT Standard Time and now the alias is set to the short timezone name.

So issue solved - thx for the help!

Show 1 Share
10 |10000 characters needed characters left characters exceeded

If your question has been answered, please mark this Discussion with a Correct Answer and Helpful Answer where appropriate. See http://scn.sap.com/community/support/blog/2013/04/03/how-to-close-a-discussion-and-why Even if you discovered the solution without any outside contributions, it helps others to understand what the solution turned out to be.

If your question or problem was answered then please mark the helpful and correct answers as such, please see also "How to close a discussion and why".

0
Subash Narayan
Oct 27, 2017 at 02:25 PM
0

Hi Joris,

Please look at the following article to add time zones in Agentry. The set of the time zones has to be deifined as shown in the article.

https://wiki.scn.sap.com/wiki/display/SAPMOB/Set+Up+Time+Zone+Alias+in+Agentry.ini+Configuration+File

Also there is also this KBA that might help:

1813025 - Troubleshooting: Client Time Zone is not recognized and no alias was found in TimeZoneAliases in Agentry.ini - Agentry

Thanks

Subash

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member
Oct 27, 2017 at 02:27 PM
0

Hi Joris,

In order to assist you with I will need a few more details from you. Please fill these out to the best of your knowledge:

Mobile Application Product/version:

SMP Server runtime version/patch:

Affected Client platform type, OS, Agentry version:

Mobile Add-On version/patch:

SAP system, EhP version:

SAP Notes applied to affected installation:

Is this standard application or custom implementation?

If Mobile Add-On issue: were customizations made?

Date when the problem began:

Known changes to the environment at the time the problem began:

Actual behavior:

Reproduction steps including video/screenshots if applicable:

Expected behavior:

Is there a workaround in place?

Thanks,

Francisco Hernandez

SAP Product Support

Share
10 |10000 characters needed characters left characters exceeded