Skip to Content

IoT service "Open Chart"

Oct 19, 2017 at 09:08 AM


avatar image


can you please help me with SCP IoT service for trial account? When I click on device and choose "Open chart" option I don't get any chart or data, but in table I can see that data is coming, can you help?

Best regards,


10 |10000 characters needed characters left characters exceeded

Hello Antun, could you please clarify if you talk about IoT for CF or Neo environment here?

Update. Some screenshot might be helpful.


May I also ask you to check the browser logs? Any warning / error messages there? And also check if you see some chart data for the "Sample device 1" and its message type "m0t0y0p0e1"? Thanks, Anton


This is the console error:

sap-ui-core.js:160 2017-10-19 14:21:15.461405 The following problem occurred: HTTP request failed404,Not Found,{"error":{"code":null,"message":{"lang":"en","value":"Could not find an entity set or function import for 'T_IOT_38AC1BE322C8A7956948'."}}}

We are not using table T_IOT_38AC1BE322C8A7956948, we are using T_IOT_MESSAGE.

* Please Login or Register to Answer, Follow or Comment.

1 Answer

Anton Levin
Oct 19, 2017 at 04:48 PM

Hello Antun,

based on above comments, that behaviour seems to be a bug in the Chart View. You have "custom table mapping" [1] configured but the chart still tries to get the message out of the default "T_IOT_%MESSAGE_TYPE_ID%" table via the OData API and fails to find such a table. Table View behaves correctly here. I will open an internal ticket for that.

Sorry for the inconvenience,


P.S. As a workaround (if you would like to visialize your data with the chart control), you may want to have a look at our UI5 sample in the StarterKit [2] and adapt it for your needs.



Show 1 Share
10 |10000 characters needed characters left characters exceeded


I've created new table with name convention like "T_IOT_%MESSAGE_TYPE_ID%" and now chart is working.