Skip to Content

SAP Web IDE SQL Select Statement does not work

Oct 18, 2017 at 02:51 PM


avatar image


it's wild, I can't figure out what's wrong with the select statement.

If I use "Wert" in the Where Clause then I don't get any result, even though the value is there. (No error messages!)

Its a NVARCHAR(15).

FROM "" where  "Wert" =  '0041715436' and  "Art" = 'SAP-Kennzahl';

I'm able to do this Select for all the other columns from this table. Its a column table.

I tried also similar tables and there it works as I would expect.

Any ideas?

sql.png (21.3 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Virendra Raval
Oct 18, 2017 at 07:30 PM

Hi Dirk,

I think the value might have space(s) in it. As the value is numeric can you please try without single quotes like "Wert" = 0041715436. If the column is of text, you may want to try it after get rid of the blank spaces.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thank you very much.

I was sure that I tried also this way yesterday, but maybe I don't. As you said, without the single quotes it works for me.

where  "Wert" =  41715436;