Skip to Content
0

Why does send an eMail work or does not work - depending on where the "perform" is?

Oct 18, 2017 at 01:51 PM

47

avatar image
Former Member

I want to create an email to be send via internet. This works completely well, if I "perform mail" from "when 'HONO'", but if I do it from "when 'SAVE'", it does create an email, but this one never gets into the queue. I have tried many variations of "commit work" and other things, but I have no idea, where the difference might be ... !

jfhqg.png (24.0 kB)
wg5iu.png (5.7 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Jelena Perfiljeva
Oct 18, 2017 at 04:17 PM
1

Not sure this can be answered based on the code fragment as we don't know what else goes on in the program... Have you tried debugging it?

If you run it through the debugger and get the same exact results then it'd seem logical to look for a problem with COMMIT. Could there be by chance an update termination?

I'm kind of skeptical that there really is no difference. Of course, the code could be exactly the same but I see you have different routines called before that and who knows what else is there. The same exact code might not have the same exact results. But you'll only find this out by debugging in your system.

Share
10 |10000 characters needed characters left characters exceeded
Vijaya Simha Chintarlapalli Reddy Oct 18, 2017 at 02:12 PM
0

Hello,

Please try using cmmit work with wait It might work.

thanks,

Vijay

Share
10 |10000 characters needed characters left characters exceeded
Mike Pokraka Oct 18, 2017 at 04:55 PM
0

Suggest commenting out the other performs to rule out some other interference, along the lines of what Jelena suggested.

If it works then, something in your other perform is suspect. Keep commenting out various bits in there until you find it.

Share
10 |10000 characters needed characters left characters exceeded
Harald Lesche-Holzbecher
Oct 19, 2017 at 06:46 PM
0

Email adress pmail1 is taken from global (?) variable zpmini-email.

Did you check it's correctly set as well for 'HONO'?

Share
10 |10000 characters needed characters left characters exceeded